My Subscription or Signup button doesnt work for others outside my network accessing my Blog

Hi there,
I run my blog within portainer and docker on a debian vm.
Its running the latest version of ghost.
Its runs within cloudflare tunnel expose to public

My blog:

When clicking on any subscribe button or signup or login no prompt comes up at all when your accessing outside the network.

It doesnt look like im disallowing access to anything other then the xxxx/ghost since i did that so people dont go to try and access the admin page.

all my newsletters and mailbox are setup properly from what i can see. Everything seems enabled or active I dont understand why its not working for others to signup.

1 Like

/ghost/ needs to be accessible because it’s where Ghost’s API lives, none of the apps like memberships or comments will work without access to the API.

1 Like

Ok thanks. That fixed it, is there any way to block usage of the admin /ghost portal i can setup with cloudflare tunnel? or not at the moment other then blocking /ghost inturn it blocking the api usage.

No, the uses of the admin API aren’t easily split now.

You can try restricting access to the Admin API by only allowing access to /ghost/api/admin/ to specific IPs or through a tunnel/VPN.

Anyone who’s not authorised can still access the client-side app that is served on /ghost/ but it will error because the Admin API isn’t accessible.