Native App for Ubuntu not Working

I tried downloading Ubuntu Native app from

The deb file does not work out of the box, it has an error that the dependency libgconf2-4 is not installable. What I did is I fixed the deb file using dpkg-deb and fixed the dependency name. (The correct name is libgconf-2-4 not libgconf2-4).

The app successfully installs but does not run. I tried running it in the command line, and I get this segmentation fault error:

The problem seems to be from the build. Is this app still maintained? I would love to blog with Ghost from my desktop.

Hmm. I had some issues on Linux as well. I’ll try again tomorrow and compare error messages. :slightly_smiling_face:

1 Like

The desktop app is a community project that has not been updated by the project maintainer for a while so there may be some package-related issues on some platforms.

However, it’s only an electron app that wraps the admin that lives on Unless you have multiple Ghost sites and want the sidebar in the desktop app for easy switching you’re not missing anything by using the web admin. If you want the same “desktop” experience of clicking an icon to open a single-site app then you could use nativefier or similar to achieve the same thing.

1 Like

That makes sense!

Guess, I’ll continue using the web version then.

OK, that project is life-changing! Nicely solves the issue of Firefox not having a ”save shortcut” option. Thanks @Kevin! :+1:

I tried installing the deb file and it worked fine on my KDE neon 5.18 setup. I was using the Flatpak; it was throwing lots of AppArmor errors in the background that resulted in each blog showing a spinning wheel without actually loading anything.

What OS are you running?

Im using Pop!_OS 19.10, my desktop is Gnome 3.34.2

This is awesome. Thanks for sharing!