I am encountering a net::ERR_TOO_MANY_REDIRECTS error when attempting to load posts. There is a significant delay, and at times, the post admin panel page fails to load. I have explored various discussions seeking a solution but have been unable to resolve the issue.

I am using Ghost with a fresh 1-click installation on Digital Ocean. I have recently added a DNS A record with my droplet’s IP. what are correct CloudFlare settings?

Try setting CloudFlare’s encryption mode to Full(Strict)

Hello Vikas garu,

I have switched it to full (strict) mode but am still encountering the issues.

I believe this might be a browser-related issue. There doesn’t seem to be any issue in the Edge browser, but both Opera and Chrome are still unable to load information about members in the dashboard. I have attempted to clear cookies and cache, but unfortunately, it has not resolved the issue.

Make sure you clear the browser’s page cache.

1 Like

You might try waiting a few hours, because browsers’ handling of redirects can be weird

After clearing the browser’s cache and cookies, it started working.

    server {
        listen 443 ssl;
        server_name ~^(.*)\.domain\.day$;

        ssl_certificate ------;
        ssl_certificate_key ------;
        ssl_protocols TLSv1.2 TLSv1.3;
        ssl_prefer_server_ciphers off;

        location / {
            proxy_set_header Host $host;
            proxy_set_header X-Real-IP $remote_addr;
            proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_set_header X-Forwarded-Proto https;
            proxy_set_header X-Forwarded-Host $http_host;
version: '3.1'


    image: ghost:5-alpine
    container_name: ghost
    restart: always
      - traefik-public
      database__client: mysql
      database__connection__host: host.docker.internal
      database__connection__user: -----
      database__connection__password: -------
      database__connection__database: ghost
      - "traefik.enable=true"

      - "traefik.http.routers.ghost.rule=Host(``)"
      - "traefik.http.routers.ghost.entrypoints=web"
      - "traefik.http.routers.ghost.service=ghost"
      - ""

      - ghost:/var/lib/ghost/content


   external: true

local access :o:
http access :warning: (mixed contents error)
https access :x: (too many redirects)

i have the same issue on both URLs.

You’ve tried clearing the cache and using private mode, but the issue persists in browsers like Edge, Chrome, and Safari.

"I encountered a specific issue with reverse proxy schemes and found a solution that I’d like to share.

Here’s my network configuration:


In this setup, NGINX properly sends requests over HTTPS. However, the problem arose because Traefik was forwarding these requests to Ghost using HTTP, causing issues in Ghost.

To resolve this, I modified the docker-compose.yml file by adding the following two lines:

yamlCopy code

- "traefik.http.middlewares.ghost-test-https.headers.customrequestheaders.X-Forwarded-Proto=https"
- "traefik.http.routers.ghost-test.middlewares=ghost-test-https"

These additions ensure that the scheme is changed to HTTPS, addressing the issue effectively."