Not all post are showing up after a json import

#1

I am basically moving my blog to a smaller server on digital ocean.
I decide to containerize ti this time and am using a bitnami/ghost image.
https://hub.docker.com/_/ghost/

Link to live site

Link of my new ghost blog based on bitnami ghost image
http://104.248.57.30/

  • What version of Ghost are you using?
    latest version

I exported JSON from the live site and imported on the migration site and that was successful.
now the issue is I am not seeing all of the posts on the migration site, and I’m not sure why.

#2

Hi @be_sem! Do you have any more information about the posts that are not showing up? Which version are the old and new Ghost instances? Did you receive any warnings when importing JSON?

#3

They are both the same age I would say, except the live one is a one-click install of ghost digital ocean marketplace,

The second is a one-click install of docker from digital ocean marketplace. I then pulled the ghost image from the docker hub.

The import only showed a warning about not being able to import the settings. I can see all the posts in the admin panel, just not in the client facing page, and it basically is when I scroll to the bottom of the page, it does not auto scroll on the container instance which is 104.248.57.30

PS. seems autoscrolling is not working on the live page either after this wildcard letsencrypt ssl install
Update, it is working again

#4

Import successful with warnings

User: Entry was not imported and ignored. Detected duplicated entry.

{“name”:“Berry Semexan",“slug”:“berry”,“ghost_auth_access_token”:null,“ghost_auth_id”:null,“password”:"$2a$10$qvvZHeoVg0XvQIQKR0N3JONC8uKuWxO4Dt4zfOOJWs5Dt9iq4Mswu",“email”:"bsemexan@gmail.com”,“profile_image”:null,“cover_image”:null,“bio”:null,“website”:null,“location”:null,“facebook”:null,“twitter”:null,“accessibility”:"{“nightShift”:false}",“status”:“active”,“locale”:null,“visibility”:“public”,“meta_title”:null,“meta_description”:null,“tour”:"[“upload-a-theme”,“getting-started”]",“last_seen”:“2019-04-06T19:37:14.000Z”,“created_at”:“2018-11-29T00:18:50.000Z”,“updated_at”:“2019-04-06T19:54:26.000Z”,“roles”:[“Administrator”],“id”:“5cabcdcba50caf0001fafa3b”}

User: Entry was not imported and ignored. Detected duplicated entry.

{“name”:“Ghost”,“slug”:“ghost”,“ghost_auth_access_token”:null,“ghost_auth_id”:null,“password”:"$2a$10$DGC6ue78WLrnCMXtElavXOClQ.xkf4Rczwgk40OpIcOfc0hmpxSU.",“email”:“ghost-author@example.com”,“profile_image”:“https://static.ghost.org/v2.0.0/images/ghost.png",“cover_image”:null,“bio”:"You can delete this user to remove all the welcome posts”,“website”:“https://ghost.org”,“location”:“The Internet”,“facebook”:“ghost”,“twitter”:“tryghost”,“accessibility”:null,“status”:“active”,“locale”:null,“visibility”:“public”,“meta_title”:null,“meta_description”:null,“tour”:null,“last_seen”:null,“created_at”:“2018-11-29T00:18:51.000Z”,“updated_at”:“2018-11-29T00:18:51.000Z”,“roles”:[“Author”],“id”:“5cabcdcba50caf0001fafa3c”}

Settings: Theme not imported, please upload in Settings - Design

{“id”:“5bff306cc5619307d6ca6c82”,“key”:“active_theme”,“value”:“casper”,“type”:“theme”,“created_at”:“2018-11-29T00:18:52.000Z”,“updated_at”:“2018-12-28T19:32:47.000Z”}

closed #5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.