SMTP docker image problem

How to solve the issue any help?

      database__client: mysql
      database__connection__host: db
      database__connection__user: ghost
      database__connection__password: ghostdbpass
      database__connection__database: ghostdb
      mail__transport: SMTP
      mail__options__host: {}
      mail__options__port: {587}
      mail__options__secureConnection: {false}
      mail__options__service: {Mailgun}
      mail__options__auth__user: {}
      mail__options__auth__pass: {Password}

services.ghost.environment.mail__options__host contains {"": null}, which is an invalid type, it should be a string, number, or a null

I’m not a Docker user, but I think you should use quotes, not braces, e.g. mail__options__host: "". Typically, braces are used with environment variables, e.g., ${MAIL_HOST}.

I did it, get same result
Why is my website not loading?

There’s nothing obviously wrong in your screenshot. If you need help, you’ll need to provide enough information to allow us to help you find the problem.

What does changing transactional email config have to do with the site not running? Did the changes eliminate the invalid type error or not?

If this issue is resolved, please mark the thread solved. And if you have another issue please start another thread.

As mentioned before, please provide relevant information to help those assisting you, and use the preformatted text option in the post editor to share system messages. Screenshots of text output is lazy, and harder to decipher, especially from mobile devices.

1 Like