SSL is only working for www. domain


#1

Hi,

I just set up ghost using Digital Ocean’s one-click setup. During the setup it asks to setup the domain and also the SSL.

When visiting [https://www.writingwhilenoodles.com] everything is as it should be, however when visiting [https://writingwhilenoodles.com] (without the [www.]) I get a This connection is not private error. Any idea how to resolve this?

On the Digital Ocean website someone suggested I create a wildcard SLL certificate, but because the process of getting an SSL certificatie is automated at Digital Ocean (you only put in your e-mail address), I’m not sure how to do this.

Could somebody help me get the SSL certificate working on both domains?


#2

www. and the root domain are two different domains. The process for setting up SSL for a secondary domain with Ghost CLI is documented here:


#3

Perfect, worked like a charm! Thanks!


closed #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.