Stripe SSL Confliction Despite HTTPS and Certificate

Recently created a Ghost instance on AWS using the provided image, and have created a valid certificate using Let’s Encrypt. Everything seems to be working find but Stripe is telling me that the instance isn’t configured to use HTTPS and isn’t using a certificate, but it is actually.

Website URL is bunkhouse.braxtonmccoy.com and the version is Ghost 4.16.0-1

Everything was installed as specified using the instructions. I’ve even tried the RequestHeader set X-Forwarded-Proto “https” fix suggested that I’ve used in the past to fix issues with images getting stuck in redirection loops. Is there something I have missed or don’t understand? I have setup a few Bitnami and Ghost stacks before in the past but haven’t connected Stripe or performed membership tiering. Please help. Thanks!

Your url is configured as http://bunkhouse.braxtonmccoy.com/ - this is the URL ghost uses for everything so if your primary site is https://bunkhouse.braxtonmccoy.com/, it needs to be configured as such :slight_smile:

When you say that I should change my configuration, are you referring to the configuration file for ghost at /opt/bitnami/ghost/config.production.json?

I assume you are, so I have tried to change the url listed in this file from “http://bunkhouse.braxtonmccoy.com” to “https://bunkhouse.braxtonmccoy.com

When this is done and ghost and apache are restarted the url begins to redirect to 127.0.0.1:2368. Does this mean that I have to also change some apache files or the port number listed? Am I missing a step or is there some guide I should follow?

I’m sorry but this suggestion to just change my url seems incomplete or oversimplified and I don’t understand. Appreciate your help but I need more detailed instructions probably.

I’m not sure how bitnami is set up so I’m not able to give much more info than that unfortunately :confused: All I can tell you is if you’re using SSL, Ghost needs to be configured with https in the URL, and the proxy server(s) need to be configured so Ghost knows that the request was originally https (usually the x-forwarded-proto header)

Thanks for your help anyway. I’ve since ensured that config.production.json has ghost configured at the root of the stack for https. It hasn’t broken Apache but still the Stripe module within the “Memberships” section of “Settings” says the application doesn’t support SSL. If anyone else can help I would appreciate it.

I’ve attached a screenshot to illustrate the problem.

I would attach another to show the valid certificate for the domain but I’m only allowed one image per post. If anyone wants to check it out you can visit the site. Any help would be appreciated.

The site url is still configured to be http - as long as the site URL is configured to be http, it won’t work!

$ curl --silent https://bunkhouse.braxtonmccoy.com/ghost/api/v3/admin/site/ | jq .site.url
"http://bunkhouse.braxtonmccoy.com/" 

Obviously I still have the problem but I can’t find where to change the configuration, can you help me with that?

I still can’t find any help with this issue. The folks on the broader Bitnami board seem to think that I have done everything correctly. Stripe not recognizing valid HTTPS on Ghost - Ghost - Bitnami Community

Has anyone had this issue or know what my configuration problem is here?