Unable to get https: on www. its working fine without it

https://neurologicaldisorders.co is working fine but https://www.neurologicaldisorders.co
is not working I’m using ghost with digital ocean its the one click install and comes with SSL install feature but I have also created www. record in DNS in namcheap

please help me guys

It looks like it’s working now, is there still an issue?

yes its still not working vikas please help me out visiting here https://www.neurologicaldisorders.co/

shows the following Websites prove their identity via certificates. Firefox does not trust this site because it uses a certificate that is not valid for www.neurologicaldisorders.co. The certificate is only valid for neurologicaldisorders.co.

Error code: SSL_ERROR_BAD_CERT_DOMAIN

share your nginx configurations of files
neurologicaldisorders.co-ssl.conf and neurologicaldisorders.co.conf

EDIT:
add this code in files if it is not already present:

if ($host = www.neurologicaldisorders.co) {
    return 301 https://neurologicaldisorders.co$request_uri;
}

can you help me locate these files ? I’m not familiar with this but i can run commands

if you just installed Ghost, the directory should be this: /etc/nginx/sites-available

you can connect via ftp

thanks man

man can you help me with this when i’m trying to update ghost i’m getting this error
:heavy_check_mark: Checking system Node.js version
:heavy_check_mark: Ensuring user is not logged in as ghost user
:heavy_check_mark: Checking if logged in user is directory owner
:heavy_check_mark: Checking current folder permissions
:heavy_check_mark: Checking folder permissions
:heavy_multiplication_x: Checking file permissions
:heavy_check_mark: Checking content folder ownership
:heavy_check_mark: Checking memory availability
:heavy_check_mark: Checking free space
One or more errors occurred.

  1. Checking file permissions

Message: Your installation folder contains some directories or files with incorrect permissions:

  • ./content/themes/Dawn-master/assets/js/lib/owl.carousel.min.js
  • ./content/themes/Dawn-master/assets/js/lib/photoswipe-ui-default.min.js
  • ./content/themes/Dawn-master/assets/js/lib/jquery.fitvids.js
  • ./content/themes/Dawn-master/assets/js/lib/photoswipe.min.js
  • ./content/themes/Dawn-master/assets/images/preloader.gif
  • ./content/themes/Dawn-master/assets/images/default-skin.svg
  • ./content/themes/Dawn-master/assets/images/default-skin.png
  • ./content/themes/Ruby-master/assets/js/lib/photoswipe-ui-default.min.js
  • ./content/themes/Ruby-master/assets/js/lib/theia-sticky-sidebar.js
  • ./content/themes/Ruby-master/assets/js/lib/lazysizes.min.js
  • ./content/themes/Ruby-master/assets/js/lib/photoswipe.min.js
  • ./content/themes/Ruby-master/assets/images/preloader.gif
  • ./content/themes/Ruby-master/assets/images/default-skin.svg
  • ./content/themes/Ruby-master/assets/images/default-skin.png
  • ./content/themes/Ruby-master/assets/fonts/selection.json
  • ./content/themes/Ruby-master/assets/fonts/IVEEL.svg
  • ./content/themes/Ruby-master/assets/fonts/IVEEL.ttf
  • ./content/themes/Ruby-master/assets/fonts/IVEEL.woff
  • ./content/themes/Dawn-dis/assets/js/lib/owl.carousel.min.js
  • ./content/themes/Dawn-dis/assets/js/lib/photoswipe-ui-default.min.js
  • ./content/themes/Dawn-dis/assets/js/lib/jquery.fitvids.js
  • ./content/themes/Dawn-dis/assets/js/lib/photoswipe.min.js
  • ./content/themes/Dawn-dis/assets/images/preloader.gif
  • ./content/themes/Dawn-dis/assets/images/default-skin.svg
  • ./content/themes/Dawn-dis/assets/images/default-skin.png
  • ./content/themes/Ruby-ds/assets/js/lib/photoswipe-ui-default.min.js
  • ./content/themes/Ruby-ds/assets/js/lib/theia-sticky-sidebar.js
  • ./content/themes/Ruby-ds/assets/js/lib/lazysizes.min.js
  • ./content/themes/Ruby-ds/assets/js/lib/photoswipe.min.js
  • ./content/themes/Ruby-ds/assets/images/preloader.gif
  • ./content/themes/Ruby-ds/assets/images/default-skin.svg
  • ./content/themes/Ruby-ds/assets/images/default-skin.png
  • ./content/themes/Ruby-ds/assets/fonts/selection.json
  • ./content/themes/Ruby-ds/assets/fonts/IVEEL.svg
  • ./content/themes/Ruby-ds/assets/fonts/IVEEL.ttf
  • ./content/themes/Ruby-ds/assets/fonts/IVEEL.woff
  • ./content/themes/Alto-master/assets/js/lib/owl.carousel.min.js
  • ./content/themes/Alto-master/assets/js/lib/jquery.slicknav.min.js
  • ./content/themes/Alto-master/assets/js/lib/jquery.fitvids.js
  • ./content/themes/Alto-master/assets/fonts/Alto.woff
  • ./content/themes/Alto-master/assets/fonts/selection.json
  • ./content/themes/Alto-master/assets/fonts/Alto.svg
  • ./content/themes/Alto-master/assets/fonts/Alto.ttf
    Run sudo find ./ ! -path “./versions/*” -type f -exec chmod 664 {} ; and try again.

Debug Information:
OS: Ubuntu, v18.04.4 LTS
Node Version: v12.18.0
Ghost Version: 3.39.0
Ghost-CLI Version: 1.15.2
Environment: production
Command: ‘ghost update’

Try running ghost doctor to check your system for known issues.

Hi, run the command that suggests the output, and then try updating again:

sudo find ./ ! -path "./versions/*" -type f -exec chmod 664 {};
I copied and pasted what you reported here, make sure it’s correct

ghost update

Next time open a new thread for a different topic

if the main problem of this thread is over, mark it as solved

1 Like

I did this but it’s still the same can you confirm so I have to put it in someplace specific I added it at the end

your files should look like this:

neurologicaldisorders.co.conf:

server {

    listen 80;
    listen [::]:80;
    
    server_name neurologicaldisorders.co www.neurologicaldisorders.co;
    root /var/www/ghost/system/nginx-root; # Used for acme.sh SSL verification (https://acme.sh)
    ssl_certificate /etc/letsencrypt/neurologicaldisorders.co/fullchain.cer;
    ssl_certificate_key /etc/letsencrypt/neurologicaldisorders.co/neurologicaldisorders.co.key;
    include /etc/nginx/snippets/ssl-params.conf;

    location / {
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header X-Forwarded-Proto $scheme;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header Host $http_host;
        proxy_pass http://127.0.0.1:2368;
    }

    location ~ /.well-known {
        allow all;
    }

    if ($host = www.neurologicaldisorders.co) {
        return 301 https://neurologicaldisorders.co$request_uri;
    }

}

neurologicaldisorders.co-ssl.conf:

server {
    listen 443 ssl http2;
    listen [::]:443 ssl http2;

    server_name neurologicaldisorders.co www.neurologicaldisorders.co;
    root /var/www/ghost/system/nginx-root; # Used for acme.sh SSL verification (https://acme.sh)
    ssl_certificate /etc/letsencrypt/neurologicaldisorders.co/fullchain.cer;
    ssl_certificate_key /etc/letsencrypt/neurologicaldisorders.co/neurologicaldisorders.co.key;
    include /etc/nginx/snippets/ssl-params.conf;

    location / {
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header X-Forwarded-Proto $scheme;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header Host $http_host;
        proxy_pass http://127.0.0.1:2368;
    }

    location ~ /.well-known {
        allow all;
    }

    if ($host = www.neurologicaldisorders.co) {
        return 301 https://neurologicaldisorders.co$request_uri;
    }

}

probably some settings are redundant and not strictly necessary, but that way it sure works.

After editing the files like this, restart nginx:
sudo service nginx restart

Open your browser, clear the cache, and the problem should be solved.

hey thanks for taking your time to help me out now both the files look the same as this one also there is a default file I have not opened that
when I opened the files neurologicaldisorders.co-ssl.conf : and neurologicaldisorders.co.conf : these lines were missing

ssl_certificate /etc/letsencrypt/neurologicaldisorders.co/fullchain.cer;
    ssl_certificate_key /etc/letsencrypt/neurologicaldisorders.co/neurologicaldisorders.co.key;
    include /etc/nginx/snippets/ssl-params.conf;

i did all this but its still the same : www.neurologicaldisorders.co/ is not resolving to https

see the configs below :

change the server_name in both files, add the domain name with www, see the examples I showed you



now it’s like this in 4 places it’s still not working please help and see if I’m missing something