Uninstalled/installed on Ubuntu 18.04, now skips Nginx/SSL setup and URL gives SSL warning

Setting up on Linode Ubuntu 18.04

I installed ghost and changed my URL a few times. It worked ok but it was redirecting from root domain to www (I thought it was an nginx issue but it might not have been). I wanted a fresh install so I did ghost uninstall and ghost install immediately after. I noticed that it skipped the nginx steps and failed. I checked the log:

Original Error Message:
Message: Command failed: /bin/sh -c sudo -S -p '#node-sudo-passwd#'  nginx -s reload
nginx: [emerg] open() "/etc/nginx/sites-enabled/www.xxxxxxxxxxx.com-ssl.conf" failed (2: No such file or directory) in /etc/nginx/nginx.conf:62

Stack: Error: Command failed: /bin/sh -c sudo -S -p '#node-sudo-passwd#'  nginx -s reload
nginx: [emerg] open() "/etc/nginx/sites-enabled/www.xxxxxxxxxxxx.com-ssl.conf" failed (2: No such file or directory) in /etc/nginx/nginx.conf:62

Subsequently, I’ve tried ghost install a few times after snooping around and it gets to the last steps but just skips Nginx/SSL setup

Now whenever I visit my URL, Chrome is giving me a “Your connection is not private warning”.

What should I do? Also for future reference, how do I make sure to go through a true uninstall without any dangling config files? I’m not really familiar with nginx.

Thanks for your help.

Hi there, can you try running ghost doctor and see what it shows? Might help with debugging it

@DavidDarnes thanks for replying david. I ran ghost doctor and it says everything is running fine (although it skipped validating config)

✔ Checking system Node.js version
✔ Checking logged in user
✔ Ensuring user is not logged in as ghost user
✔ Checking if logged in user is directory owner
✔ Checking current folder permissions
✔ Checking operating system compatibility
✔ Checking for a MySQL installation
+ sudo systemctl is-active ghost_semi-anonyme-blog
Instance is currently running
ℹ Validating config [skipped]
✔ Checking folder permissions
✔ Checking file permissions
✔ Checking content folder ownership
✔ Checking memory availability

That error I posted in the original post seems suspect to me though… I’m thinking I screwed up an nginx conf file, and if that’s the case, I unfortunately do not know enough about nginx to do something about it

Who is your hosting provider? Are they able to help out?