Update SSL certificate for a changed domain

So, I just moved my blog from vikashkoushik.com to content.vikashkoushik.com, so i can access my admin panel while i move to gatsby via netlify. however, I’m running into an error during build in netlify.

here’s the error I’m getting during build:

error "gatsby-source-ghost" threw an error while running the sourceNodes lifecycle:
6:02:52 PM: getaddrinfo ENOTFOUND content.vikashkoushik.com content.vikashkoushik.com:443
6:02:52 PM: 
6:02:52 PM:   Error: getaddrinfo ENOTFOUND content.vikashkoushik.com content.vikashkoushik.c  om:443
6:02:52 PM: 
6:02:52 PM: not finished source and transform nodes - 0.129s

i think it’s because content.vikashkoushik.com doesn’t have https.

Trying to run ghost setup nginx ssl says:

It is recommended that you upgrade before continuing.
Run `npm install -g ghost-cli@latest` to upgrade.

Nginx configuration already found for this url. Skipping Nginx setup.
ℹ Setting up Nginx [skipped]
Nginx setup task was skipped, skipping SSL setup
ℹ Setting up SSL [skipped] 

when i tried to update cli, i got this error:

Error: EACCES: permission denied, unlink '/usr/bin/ghost'

so i ran the update as root and it was updated to 1.14.0. but running ghost version tells me that i’m in 1.13.1.

So i’m stuck in this loop of trying to get a ssl for content.vikashkoushik.com unable to because i’m asked to update version -> running into an error when updating CLI.

I’m not sure how to proceed with this error. Any help?