Upgrade not possible since 1.22.1


#1

Hello!

I am using Ghost selfhosted. Every last update was working fine, now I cannot longer update.

Ghost version: 1.22.1
Ghost cli version: 1.7.1

I created a own ghost user for ghost, all files are belong to the user, but when I start the ghost update command, I got this error:

:heavy_multiplication_x: Ensuring user is not logged in as ghost user

Can someone help me with this?

Thank you
Tim


#2

Hey @timscha :wave: If you run ghost doctor do you get more info or links for how to fix your install? The install instructions state to never use the ghost user directly https://docs.ghost.org/docs/install#section-create-a-new-user


#3

Hi @Kevin
Tried it. I fixed it for me now, creating a new user, because my old user was called “ghost”.
This worked for me for months. Did you guys changed this behaviour in the past?
Nevertheless, after reinstall the systemd file, it is working now.

Thank you.


#4

Using the ghost user directly was always discouraged because it will fail and cause problems in certain circumstances but an explicit check for it was only added to Ghost-CLI recently which is probably why you’ve only just noticed it.


#5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.