Warning ghost@2.25.4: The engine "cli" appears to be invalid

Hi all. I am very new to Node and Ghost, so apologies if this ends up being a basic question. But I have not been able to find my answer searching this forum and elsewhere online.

I successfully installed the development environment for Ghost on my MacBook Pro two days ago. After some playing around, I wanted to delete it and reinstall it from scratch. So I am now attempting a development reinstall of the Ghost 2.25.4 on my MacBook Pro.

I’ve tried carefully following the instructions on the Install From Source page as I did the first successful time. But I’m now getting this error during yarn setup:

warning ghost@2.25.4: The engine "cli" appears to be invalid.

And I get an error message like this when I run grunt dev:

INFO "GET /ghost/ember-cli-live-reload.js" 302

I have tried deleting and reinstalling ember-cli, clearing Yarn’s cache and running yarn setup again, and starting over from scratch three times. Nothing is helping.

What am I missing here? Many thanks for any help.

Hey @marclafountain :wave:

When you say “a development reinstall”, what are you trying to do - are you trying to develop a Ghost Theme, or make a Ghost Core change? If you’re trying to develop a theme, there’s a much easier way to get started; check out the docs here:

For core development…

Note that it’s normal to get the engine "cli" appears to be invalid warning… Yarn doesn’t know how to validate the Ghost-CLI version; the CLI handles that validation elsewhere.

The message you receive when you run grunt dev isn’t an error message, rather log output from Ghost saying there was a request to /ghost/ember-cli-live-reload.js. This is expected as well.

Hi, @vikaspotluri123. Thanks for the quick reply.

I’m trying to experiment with changes to Ghost Core. I’m working on one of the Good First Issues around the post date picker to try and learn.

When I initially followed the Install From Source instructions to create a development environment on my MacBook Pro, I don’t remember seeing error messages around CLI. (Perhaps I missed them.) I also didn’t initially have any issues with the date picker, even when I made changes to it.

When I tried to delete my local repos and follow the Install From Source instructions again, I’m now seeing these CLI errors and the date picker no longer saves dates. To be clear, that odd behavior is happening on an unaltered version of the master branch. I haven’t changed anything (at least that I can tell).

Any ideas?

So the current issue you’re having is your latest build on master doesn’t have a functional date picker, correct?

Well, yes. But since the date picker is what I’m working on, that’s what I’m noticing. I don’t know if there might be other issues.

Basically, I don’t recall CLI errors from my development environment two days ago and the date picker worked fine there. Now I see the CLI errors and have a date picker issue in this new development environment.

To be clear, I’m a newbie and this is probably a problem I’m causing somehow. I just don’t know how.

can you run git remote -v and git branch?

For Ghost:
|origin|git@github.com:marclafountain/Ghost (fetch)| |origin|git@github.com:marclafountain/Ghost (push)| |upstream|git@github.com:TryGhost/Ghost.git (fetch)| |upstream|git@github.com:TryGhost/Ghost.git (push)|

For Ghost-Admin in core/client:
|origin|git@github.com:marclafountain/Ghost-Admin.git (fetch)| |origin|git@github.com:marclafountain/Ghost-Admin.git (push)| |upstream|git@github.com:TryGhost/Ghost-Admin (fetch)| |upstream|git@github.com:TryGhost/Ghost-Admin (push)|

I am on the master branch for both.

Not sure that it matters, but I see this red JavaScript Console error when I am in Ghost Admin on the post settings page:

[Error] Viewport argument key "minimal-ui" not recognized and ignored. (ghost, line 12)

I have tried a fourth time to start from scratch using the unmodified source and still the date picker won’t update dates even thought I haven’t made any code changes at all on my local repo.

Thanks again for your help.

Problem solved! Apparently the date picker allows you to click on dates on an unsaved draft post but doesn’t save the dates you click on. (Kinda odd behavior.) I must somehow must have missed that. :grimacing: Very sorry to bother! Thanks for your help!

I’m glad you got it working! Good luck :slight_smile: