Yarn setup won`t work

Hi when try to install locally from git yarn setup fails.

link to tutorial

yarn run v1.22.11
warning ghost@4.13.0: The engine “cli” appears to be invalid.
$ yarn install && knex-migrator init && grunt symlink && grunt init || (exit 0)
internal/modules/cjs/loader.js:892
throw err;
^

Error: Cannot find module ‘C:\Users----\AppData\Roaming\npm\node_modules\yarn\bin\yarn.js’
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:889:15)
at Function.Module._load (internal/modules/cjs/loader.js:745:27)
at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:76:12)
at internal/main/run_main_module.js:17:47 {
code: ‘MODULE_NOT_FOUND’,
requireStack:
}
Done in 0.18s.
do you have suggestion why fails? to setup ?