2.0 to 3.0 - Can't upgrade - lockup on "Checking for latest..."

As simple as the title implies - I am running ghost update --force and I get stuck on “Checking for latest Ghost version”

Why am I using force? Ghost CLI keeps telling me I am on V1 (I’m not) and I’m out of date (probably because I am not v1)

kris@host:/var/www/ghost$ ghost version
Ghost-CLI version: 1.11.0
Ghost version: 2.31.0 (at /var/www/ghost)
kris@107-173-23-162-host:/var/www/ghost$ npm install -g ghost-cli@latest
/home/kris/.nvm/versions/node/v10.16.1/bin/ghost -> /home/kris/.nvm/versions/node/v10.16.1/lib/node_modules/ghost-cli/bin/ghost
+ ghost-cli@1.12.0
updated 1 package in 7.703s

Stack: Error: You are about to migrate to Ghost 2.0. Your blog is not on the latest Ghost 1.0 version.
    at packageInfo.then (/usr/local/lib/node_modules/ghost-cli/lib/utils/resolve-version.js:82:39)
    at process._tickCallback (internal/process/next_tick.js:68:7)
kris@107-173-23-162-host:/var/www/ghost$ ghost update --force
You are running an outdated version of Ghost-CLI.
It is recommended that you upgrade before continuing.
Run `npm install -g ghost-cli@latest` to upgrade.

+ sudo systemctl is-active ghost_www-centerofthemultiverse-net
✔ Checking system Node.js version
✔ Ensuring user is not logged in as ghost user
✔ Checking if logged in user is directory owner
✔ Checking current folder permissions
✔ Checking folder permissions
✔ Checking file permissions
✔ Checking content folder ownership
✔ Checking memory availability
✔ Checking for available migrations
☱ Checking for latest Ghost version

v3 requires ^1.12.x ;)

If you’re not getting 1.12.x, that means you probably have multiple versions of the CLI installed

There’s some discussion relating to that here:

So, I got the CLI to the correct version - now it is telling me node version is wrong - I cannot find what version of node I should upgrade to on the site. :<

It was a permission issue on my .nvm folder. Needed to allow read.

Usually any active version of LTS is supported