All image links broken after upgrade/import (v3 to v5)

While looking for a solution I saw many people having problems with loading assets, but nobody seemed to have my problem.
So here is my problem/solution.

I was upgrading an old site from a v3 to v5.
I don’t see how this is relevant, but it may be.
I upgraded two site from/to very similar versions with no problem. Using Docker with each instance. I can reference the .json for exact versions if someone want’s to help troubleshoot.

  • After importing the old .json all content worked other than images.
  • New image uploads worked fine
  • Errors related to import included 3 problems, one possibly related: Settings: Theme not imported, please upload in Settings - Design

Exploring the filesystem I noticed that /current/content/images/ was empty and my files mount to the image at `/content/images/’

For now I deleted the default created dir and added a symlink to fix the problem, because that’s how I thought it worked before.
ln -s /var/lib/ghost/content/images /var/lib/ghost/current/content

I checked one of the other ghost blogs I admin and /var/lib/ghost/content/images contains only the default created dir (empty other than, so although my workaround has worked for now it’s not working the same was as my other instances.

If anyone has a better idea I’m interested in a solution that doesn’t involve altering the docker image with a symlink.

Each blog has had unique issues while trying to upgrade, and I don’t understand the what/why/how of the process.
Maybe there are some docs I’ve not found?

I hope this helps someone - or someone can help me.