An unexpected error occurred: \"EACCES: permission denied


#1

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

- What version of Ghost are you using?
ghost 1.9.2
- What configuration?
ubuntu 18.04
- What errors or information do you see in the console?
ghost install
:heavy_check_mark: Checking system Node.js version
:heavy_check_mark: Checking logged in user
:heavy_check_mark: Checking current folder permissions
:heavy_check_mark: Checking operating system compatibility
:heavy_check_mark: Checking for a MySQL installation
:heavy_check_mark: Checking memory availability
:heavy_multiplication_x: Checking for latest Ghost version
A ProcessError occurred.

Message: Command failed: yarn info ghost versions --json
{“type”:“error”,“data”:“An unexpected error occurred: “EACCES: permission denied, scandir ‘/home/cmlanche/.config/yarn/link’”.”}

{“type”:“info”,“data”:“If you think this is a bug, please open a bug report with the information provided in “/var/www/ghost/yarn-error.log”.”}
{“type”:“info”,“data”:“Visit https://yarnpkg.com/en/docs/cli/info for documentation about this command.”}

Exit code: 1

Debug Information:
OS: Ubuntu, v18.04
Node Version: v8.11.4
Ghost-CLI Version: 1.9.2
Environment: production
Command: ‘ghost install’

Additional log info available in: /home/cmlanche/.ghost/logs/ghost-cli-debug-2018-09-02T07_46_34_082Z.log

Try running ghost doctor to check your system for known issues.

I tried twice, and failed with the same error, please help me


#2

problem solved, I donot have the perssion of dir /home/cmlanche/.config,

sudo chown <username>:<username> ~/.config

use it sove it


#3

the install doc(https://docs.ghost.org/docs/install) do not say it need ~/.config permission


#4

This issue is tracked here. We are working on a solution.


#5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.