Are there any restrictions in using ports for webhooks?

I tried to use the webhook-function when a member is modified. If I test with it works. If I test with RapidAPI (like Postman) the hook is responding with a 200 correctly, firewall is configured.

I am using as URL (sample only, port is really 3773). The call does not reach the server. It looks like it was never sent. Are there any restrictions in using ports for webhooks? What could be the problem?

Thanks for any suggestions in advance!

There shouldn’t be any restrictions from Ghost’s side. Do you perhaps have a firewall or similar that’s blocking the outgoing request from the Ghost instance? Also, have you checked your logs to see if Ghost is erroring when it tries to make the webhook request?

Hi Kevin,
thank you for taking care!

If I use Zapier for this webhook it works fine. Firewall is OK, otherwise Zapier would not work? It is open for all IPs …

And no, there are no entrys in my logfile - this is the reason why I ask.

Thank you again!

Zapier uses port 80 which is typically an allowed port in a firewall which is why I asked because you are using a non-typical port.

Hi Kevin, thank you again. Please find my Zap here:

This is working perfectly - includes all data. As I mentioned: Ghost does not even appear in the eventlog … must be something else?

Thanks again …

1 Like

Ok, I’m a bit confused, so you’re saying Zapier can’t talk to an address with a port? I was under the impression you were having problems getting Ghost to make a web hook request directly to an address with a port.

Can you start from the beginning and detail exactly what you’re attempting to do, how you have it set up, and what isn’t working?

1 Like

Sorry if I was not precise in my question. I simply created a webhook in ghost:

This does not work, even not show up on our server. Exactly the same request in Zapier works. To be true: I just want to do it from Ghost to save the Zapier fee (I just took one month ;-)

I used Zapier only to proof that our webhook is working.

Thank you again and again …

1 Like

Ok, so two things

  1. Have you checked your Ghost logs to see if there are any errors when it tries to make the web hook request?
  2. Have you confirmed that your Ghost instance is able to make outgoing connections to non-standard ports? (You can’t test this with Zapier as that will use port 80 for the Ghost->Zapier connection)
1 Like

Yes, nothing in there except the edit of the Zapier-Event (which worked fine):

I do not know how I could test this. Is there any setting I missed? The triggering of an event seems not to show up in the history anyhow. (Is “history” above what you meant with Logs?)

Thank you again for your time, very nice!

1 Like

No, the history won’t show anything like that. I meant your server logs

1 Like

Sorry, I am using the hosted version - I am using WordPress yet but I learned hate it. I would prefer the hosted version. Is there any option to see the logs of Ghost Pro site?

1 Like

Oh, I didn’t realise you were on Ghost(Pro). In that case, email to get direct help, this forum is for community support and self-hosters :slight_smile:

1 Like

Ooops. This was not obvious for me. I will do what you suggested, thank you.

May be I will post the results or the solution here later …

1 Like