Error with webhook triggers on Self-hosted Ghost

Hi! I’ve deployed an instance of Ghost for publishing my articles, thoughts and other stuff, and I’m trying to configure some triggers to execute some automations on n8n. The point is that all the triggers from Ghost produces the same warning message:

“WARN Request to https://n8n.mydomain.com/webhook/19c97ac9-3464-… failed because of: .”

I tried locally and on my server, both on Docker, and get the same error, and the trigger is not executed.

I tried to change permissions to 777, but not works. Any idea?

Thanks a lot! Best regards!

1 Like

Can you test the webhook using https://webhook.site/?

It’ll provide a bit more information on what’s happening.

1 Like

Oh, damn! It was my fault! I’ve my n8n instance secured behind a reverse proxy with basic auth… Thanks for this tip, that’s help me find the problem. Sorry for this mistake.

Thanks again for your help and best regards! :slight_smile:

1 Like

Happy you figured it out. That webhook.site is a great resource for troubleshooting webhooks. :smile:

Hello!

Didn’t want to open a new thread, but I have a similar problem. I’m trying to get a “new member” webhook working with Mattermost platform.

I have already working webhooks towards that platform, but can’t seem to get Ghost webhooks to work.

When testing with webhook.site, there are no errors just a nice JSON content. Also, testing my webhook URL via a simple CURL with --data I also get hits.

On top of this, when testing via Zappier, it all works fine so I am using that as a workaround atm. But, I would really like to get to the bottom of this as I can’t see any problems on the destination or source logs (docker logs) that might point me in the right direction.

Haven’t had this configured before, so not sure what the usual suspects might be. Just wanted to point out that none of the actions work, not just add new member.

Thank you in advance for any info on the matter.

Regards,
Luka

I’m facing the same issue. My n8n installation sits behind a Cloudflare tunnel, and the webhook is returning me the same error when trying to send the webhook to my installation.
I’ve tested the webhook with postman, and it works without anything strange in the response.