Authentication failure/user not found on a fresh install of ghost. Reinstall doesn't solve the problem either


#1

I’m facing authentication problem in trying to login to the admin panel after a fresh install. A few days ago I was able to login during the initial setup, but authentication problems started right after. Now I’m unable to login and there’s no way I can fix it, forgot password doesnt work. I tried clicking on forgot password without filling the password field, and it said user not found. I have tried ghost uninstall and installing again, but to no avail. ghost doctor doesn’t find any problems with installation.
I followed the standard procedure for deployment on DigitalOcean (Ubuntu 18using official setup guide with default settings using ghost-cli.

Ghost-CLI version: 1.9.9
Ghost version: 2.14.3
Ubuntu 18.04.1 LTS
MySQL Database (mysql Ver 14.14 Distrib 5.7.25, for Linux (x86_64) using EditLine wrapper)
Nginx
Node (installed using nvm) - I made the mistake of installing node using nvm first as root, then as a user ‘blog’

I have used Firefox and Chrome, but get the same authentication error.

Can someone help me? I’m open to do a completely fresh install too but seems like this could be a bug, so I might as well see if there’s any fix.


closed #2

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.