AWS SES Setup Correctly - Email Working but can't invite staff

hello,

I setup AWS in the config according to the tutorial.

"mail": {
    "from": "'Primates' <stan@primates.dev>",
    "transport": "SMTP",
    "options": {
      "host": "email-smtp.eu-west-1.amazonaws.com",
      "port": 465,
      "service": "SES",
      "auth": {
        "user": "XxXXXXXX",
        "pass": "XXXXXX"
      }
    }
  },

The Test email configuration in lab works
But when I want to invite new staff it gives me:
Error sending email! Error sending email: Failed to send email. Reason: Message delivery failed: 554 Message rejected: Email address is not verified. The following identities failed the check in region EU-WEST-1: test@test.com. Please check your email settings and resend the invitation.

It looks like it tries to use test@test.com as from.

Hey @StanGirard, the error above makes us think that you’ve not completed your Amazon SES setup. Would you be able to check?

Hello,

The setup was finished and working with nodemailer. The issue seems like it is trying to send as the recipient.

:wave:t3: To receive an email through Amazon SES, the email address must be verified. https://docs.aws.amazon.com/ses/latest/DeveloperGuide/verify-email-addresses-procedure.html

Thanks for your answer.

As mentioned above the email address was verified in the AWS SES.
To explain further. I tried to send an email to test@test.com but the error looks like the email tried to be sent from test@test.com and not my email address.

Here is a screenshot so I don’t have this answer again :rofl:

Also as mentioned above. The test email worked.

I’m experiencing exactly the same error. Ghost is trying to use the emails to address as it’s from address when using Amazon SES as the service provider.

I just ran across this. And one thing that I did during testing is your SES will be in Sanbox mode by default. When you’re in sandbox mode, you have to ALSO verify your testing “send-to” address in SES.

So I added my testing recieving email address and was able to test correctly. You then request to be removed from sandbox and things work as expected!

Resources:
Resolve the 554 or 400 “Message rejected” error on Amazon SES

Same error here (btw I had to dig in content/logs to find the error message):

Error: Message failed: 554 Message rejected: Email address is not verified. The following identities failed the check in region US-EAST-1: noreply@gmail.com

When I try to change the email in “Newsletter email address” from noreply@<my-IP> is returns the error above and the button turn red, with “retry”.

Any help appreciated.

In config.development.json:

  "mail": {
    "transport": "SMTP",
    "from": "my-email@gmail.com",
    "options": {
        "host": "email-smtp.us-east-1.amazonaws.com",
        "port": 465,
        "service": "SES",
        "auth": {
            "user": "my-ses-stmp-user",
            "pass": "my-ses-stmp-password"
        }
    }
  }