Blog's icon has Ghost's official icon

Hey guys.

I changed to a custom favicon in the design of my website and on the website it appears to have the custom favicon I’ve uploaded but when I search my website on Google. The website appears there with Ghost’s icon instead of mine.

Any idea how I can change that?

Are you using Google Search Console (Official Ghost + Search Console Integration)?

Requesting a new crawl will also trigger a new request for your favicon.

I am. Followed those steps a few days ago. Do I request a new crawl by clicking URL Inspection in GSC and copying the desired URL, then clicking Request Indexing?

Yep, that’ll work. Expect it to take several days before you get recrawled, and then perhaps several more days before the favicon shows up everywhere.

Thanks for the reply, Cathy! Mind if I ask for your help in explaining to me what “URL is not on Google” means? When I pass a certain blog URL into URL inspection it shows that:

I’m not sure what the Author URL has to do with this page does that message mean that I’ve done something wrong or does it just tell me that it will take time to show?
It also says N/A in Indexing allowed. Does that mean that robots.txt disallowed it?
Here’s my sitemap:

Sorry for that, I really want to know what all that means.

The referring page is where Google found the link to the page you’re referring to. Crawled but not index can just mean that Google hasn’t gotten to it yet.

Did you submit your sitemap to Google? Do that, if you haven’t already. Huh… wait a second. Why isn’t your site providing a sitemap-posts.xml file? It’s missing, and that’s likely to be a problem. Question: Are you setting the canonical url for each post to the post URL? If so, don’t. That causes Ghost to not include the site in the sitemap.

1 Like

I did upload my sitemap. After doing some research about canonical URLs I realized that it was a mistake and tried to remove the URLs I’ve given to the posts but for some reason after removing them the Update button wasn’t clickable. I’ll just make a new post and not fill out anything in the Canonical URL and Post URL and see how it goes, or is there another way to remove the URL I set and just let Ghost generate the URL? Will that bring back the sitemap-posts.xml file?

Overall, Do I have to type in anything in the Post URL? Because it seems that it’s what setting up the Canonical URL

You do NOT want to fill in a canonical url (under metadata) unless you’re telling Ghost (and Google) that the actual source of this content is not the Ghost site.

You should be able to delete the canonical URL and update, which you can trigger by pressing ctrl (or cmd) S. I’d try that for a couple posts and see if the sitemap reappears before doing them all…

There it is! I can see now the /sitemap-posts.xml . Thank you, Cathy :slight_smile:
Will know from now on.

So now that it appeared in the sitemap.xml file that these posts are crawlable as well right?

Yep. :) I’d submit the sitemap-posts.xml to GSC as another sitemap to encourage it to get moving on them. :)

Just have! Thank you so much for your patience, Cathy :pray:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.