Bulk Mail Works, But I Can't Invite Staff

What’s your URL?

What version of Ghost are you using?
I have version 4.18.0 with CLI version 1.17.3

How was Ghost installed and configured?
I installed using the one-click install and it is hosted on Digital Ocean
What Node version, database, OS & browser are you using?
Brave Browser (built on Chromium like Chrome), unsure on database (the standard one I guess), Node version 14.18.0

What errors or information do you see in the console?
I updated my config.production.json file to be set up with Mailgun. Emailing blog posts to members has worked perfectly. I just tried to invite a Staff member though and the email does not go through. I see this error:

This is what my ghost log looks like

I have done a lot of research and my mail config looks correct so I am confused what is causing this issue. Here is my mail config

"mail": {
    "transport": "SMTP",
    "options": {
      "service": "Mailgun",
      "host": "smtp.mailgun.org",
      "port": 587,
      "auth": {
        "user": "MY MAILGUN USERNAME",
        "pass": "PASSWORD HERE"

I seem to have figured it out by adding

“secure”: false

to the mail section of the config file.