Ghost Mailgun integration Doesn't Work. Need Help

I have a self-hosted ghost on digitalocean for my blog . However, I am unable to get the emails to work. I have a mailgun downgraded to the FREE plan. DNS, MX records, CNAME on Mailgun have a verified tag against them. Below is a screenshot of Mailgun config on the console. I went through several other blogs regarding the same issue and couldn’t figure out a way to troubleshoot this. Any help is much appreciated.

Attached mailgun config

@mjw Any help is much appreciated :pray:

If you look in your Ghost logs you should see an error message that will be helpful in working out what exactly isn’t working.

My hunch is that you’ll need "secure": false. The naming of that config is unfortunate because it doesn’t mean it’s not secure, instead setting to false allows the library to connect normally before negotiating a common secure cipher for TLS.

1 Like

I tried signingup and then ran the ghost log command to get this output. Is this what you are looking for?

Also I noticed that there are multiple versions of the config.production.json. Is this ok? The screenshot of the config i is from save.6. Should I delete the rest?

That log is unrelated and is an expected error when checking if a member is logged in. You’ll need to find the log line that’s related to the failed email send.

For the config files the only one that will ever be read is the config.production.json, I’d delete all of the .save files to avoid any confusion.

How can I access the log files you wanted to see? Any command that I can run for the logs and to delete the unnecessary files?