Can not connect to stripe test mode due to SSL restriction

I am running Ghost in development mode locally. In the older version of Ghost, I could connect to Stripe in test mode for testing purposes while developing themes. Currently, there is a stripe connect button but it is disabled and showing SSL issue.

Screenshot 2021-08-17 224859

Is there any solution to this?

Hey! I had the same issue. You’ll need the Stripe CLI installed locally and then you’ll need to set up the forwards. This post here was helpful for me:

Hope that helps!

Actually, that question was asked by me a while ago. But the problem in this question is different than that question.

Anyways, are you able to connect to the stripe from the dashboard in a local development installation?
The ghost version is the latest version.

Nevertheless, thank you very much for your helping intention.

Sorry! I should have read that more carefully.

I can connect to Stripe from the dashboard. In a fresh install, I went to Settings > Membership and then Portal Settings. (Not the dialog at the bottom of the page.)

In the Portal Settings modal that comes up, there’s a Connect to Stripe button. That brings up a second modal, where there’s a Connect to Stripe button and a “test mode” switch. The Connect with Stripe blue button then takes me to the authorization page where it shows me my accounts, and then there’s an orange “Test mode, skip this form” dialog. If you skip the form, it’ll show you your secure key, and you can copy and paste it into the Connect with Stripe modal.

From that point on the Stripe CLI shows me that it’s reading things sent to the web hooks, even though the Settings > Membership page doesn’t show me connected to Stripe.

Please don’t be sorry, it happens to all of us.

I have followed the same step you described but it did not solve the issue. Please see the following screenshots. Also because of this Issue, I can not add complimentary subscriptions to the members which I had created before.

What does your Stripe CLI show on the command line?

Nothing specific is being logged in stripe CLI

Uploading: stripe-cli.png…

I have also tried to debug by comparing network requests and the database. Few of the keys are in payload but not being saved in the settings table in the database.

payload