Cannot create snippets containing multiple HTML

Issue Summary

  • Explain roughly what’s wrong
  • What did you expect to happen?

I am trying to create a multiple node snippet including text, html, etc.

I tried:

  • To select manually with clic & drag all the items and it does not show the toolbar to create the snippet.
    Moreover, I cannot know if nodes are selected (except text) because there is no “active”/selected visual state
  • To create a new post containing only the snippet content, hit CTRL+A and creates the snippet.
    But either I am on a text node and it triggers the blockquote feature (which should be triggered using CTRL+Q, French keyboard issue??) or I am on a HTML node and it does nothing…
  • Even tried to create snippet directly in Database using MySQl query but that is a work around that is not viable at all…

I succeeded (by chance?) in a previous version of Ghost but now it does not work anymore.

Steps to Reproduce

Follow these steps firstly in a non empty post and then in an empty post.

  1. Create 1 HTLM node
<div class="row jusitfy-content-center">
  <div class="col-12 col-md-6 col-lg-5">
  1. Create text node “Column 1 content”
  2. Create 1 HTML node
       <div class="col-12 col-md-6 col-lg-7">
  1. Create text node “Column 2 content”
  2. Create HTML Node
  1. Try to clic, drag and select all the nodes you have just created → Does it work? Do you have the snippet toolbar displayed?
  2. Repeat the node creation in an empty post
  3. Hit CTRL+A to select all nodes → Doest it work? Do you have the snippet toolbar displayed?

Both tries lead to negative answers on my browser/ghost installation…

Setup information

Ghost Version
Ghost version : 5.62.0 with Beta Editor (tried without, not working neither)

Node.js Version
If self-hosting - share which version of Node.js you’re using.
Using Ghost Alpine docker image

How did you install Ghost?
Provide some details about your install of Ghost if you are self-hosting.
Using docker

Provide details of your host & operating system
Include further details about your hosting and OS.
Debian 10

Database type

Browser & OS version
Firefox 117.0.1 (tested on Ubuntu & Windows 11)
Works sometimes on Google Chrome with a good patience…

Relevant log / error output
No errors

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.