Can't set domain up

Hi, I tried setting up Ghost with DigitalOcean’s 1-Click.
I set up DNS and all for my domain, and when doing the setup, i used the domain as the blog URL, which when visited, always gave an error, because it tried redirecting too many times.
So i tried again, I got a fresh install and this time I entered the IP adress as the blog URL, which worked a bit better, but still not perfectly. The domain works this way, even when opening posts from the homepage, but using any links from the navbar breaks it.

So I figured, because this way the domain at least partly works, how can I change the blog URL after setup?

Did more digging with the developer tools of my browser, when visiting the domain that was set as the blog url, there are 21 GET requests that get a 301, moved permanently status, and after that, my browser displays a “The page isn’t redirecting properly” error. But when visiting from the IP address, the site works just fine. Since if I set the IP as the blog URL, i can visit the site through the domain, i would assume this is something going wrong with ghost, and not Nginx.

For a kind of temporary solution, I found that if i set up the blog URL to be something like localhost, i can set up the domain’s DNS to be directed at the IP, and that way I can access the site through the domain. After that, after that, I simply changed the navigation settings at to be directed at the domain, this way the site works mostly fine, except for when I’m reading a post, and instead of clicking on Home, I click on the site title, which leads me to localhost, or whatever you set up as the site URL.

Found what caused my problems, looks like the bunch of redirects happened because of Cloudflare, but turning off the Cloudflare Proxy on the domain solved the problem.