Can't update Ghost to the latest version 2.12


#1

hi there!
I have tried to update ghost from 2.11 to 2.12 many times and Its impossible. Error information below.
Node Version: 10.15.0 (I also tried with others…)
Ghost Cli (latest)
Ubuntu 14 (digital ocean) (updated with apt-get 2 days ago)

Am I doing something wrong?

note: I don’t now why the debug information says “node 8.9” and the console says “10.15”…


Node
xxxxxx@ghost-xxx-xxxxx-01:/var/www/ghost$ nodejs -v
v10.15.0

the error says:

:heavy_multiplication_x: Downloading and updating Ghost to v2.12.0
A ProcessError occurred.

Message: Command failed: yarn install --no-emoji --no-progress
warning ghost@2.12.0: The engine “cli” appears to be invalid.
error eslint@5.12.1: The engine “node” is incompatible with this module. Expected version “^6.14.0 || ^8.10.0 || >=9.10.0”. Got “8.9.1”
error Found incompatible module

yarn install v1.12.3
[1/5] Validating package.json…
[2/5] Resolving packages…
[3/5] Fetching packages…
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

Exit code: 1

Debug Information:
OS: Ubuntu, v16.04
Node Version: v8.9.1
Ghost-CLI Version: 1.9.9
Environment: production
Command: ‘ghost update’


#2

Hm looks like the min node version of Ghost & eslint is different.

Ghost: ^8.9.0
eslint: ^8.10.0 (see decision)

You have to correctly symlink nodejs to node, then it will work.
Please follow our node.js installation instruction.

I’ve raised https://github.com/TryGhost/Ghost/issues/10420. We need to figure out why it errors at all, because eslint is a dev dependency :woman_shrugging:t2:


#3

HI! thank you for your time.
I tried using the instructions in the link step by step with no errors at all. Then I tried running the “ghost update” command again and it still fails.
Is there any other workaround? or I will have to wait until someone fix the bug.
thx!!!

Console

✔ Checking system Node.js version
✔ Ensuring user is not logged in as ghost user
✔ Checking if logged in user is directory owner
✔ Checking current folder permissions
✔ Checking folder permissions
✔ Checking file permissions
✔ Checking content folder ownership
✔ Checking memory availability
✔ Checking for available migrations
✔ Checking for latest Ghost version
✖ Downloading and updating Ghost to v2.12.0
A ProcessError occurred.

Message: Command failed: yarn install --no-emoji --no-progress
warning ghost@2.12.0: The engine "cli" appears to be invalid.
error eslint@5.12.1: The engine "node" is incompatible with this module. Expected version "^6.14.0 || ^8.10.0 || >=9.10.0". Got "8.9.1"
error Found incompatible module

yarn install v1.12.3
[1/5] Validating package.json...
[2/5] Resolving packages...
[3/5] Fetching packages...
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

Exit code: 1


Debug Information:
    OS: Ubuntu, v16.04
    Node Version: v8.9.1
    Ghost-CLI Version: 1.9.9
    Environment: production
    Command: 'ghost update'

#4

You are still using node 8.9.1. To get rid of this error for now you need to update to 8.10.x


#5

Hi,
every time I run:

curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash -
sudo apt-get install -y nodejs

I just get the 8.9.1… I can’t find the way to update to 8.10
thats basically the reason I’m still asking for help =(


#6

Solved.
Just in case anyone have a similar issue:


thx


#7

I’m not an expert but that command seems the install command rather than the update/upgrade command. You have some options here (they seem a bit different):

Another option here:

I just updated my nodejs from v6.16 to v8.15 using these two commands (ubuntu 16.04 - exactly the commands you used, it seems):

curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash -
sudo apt-get install -y nodejs


closed #8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.