Change in Tags?

Did something change between Ghost version 3.34.1 and version 3.41.3 with regard to Tags?

I have 2 sites running the exact same version of my theme,

In the Ghost version 3.34.1 instance it DOES work… (the tags DO show on hover of the navigation button):

In the Ghost version 3.41.3 instance it DOES NOT work… (the tags DO NOT show on hover of the navigation button, even though the container DOES show as well):

On BOTH sites the hover on the Authors button IS WORKING…

I would sure appreciate any help or ideas on why this might be…

How I fixed it (in case it might help someone else with a related problem)…

I removed the code that applied a filter to the list of tags (the blue highlighted code below):

Can you directly explain the difference? The URLs don’t make any sense as they’re nothing alike.

Also just to be clear, 3.34 doesn’t shorten to 3.3 - 3.3 was 31 minor releases earlier.

Thank you @Hannah - I’ve now removed the live site URLs since I solved the error, and also corrected the referenced version numbers. Sorry for the confusion.

In terms of the code that you “fixed”, this issue is that tags don’t have tags, so filtering tags on tags doesn’t make sense, I think you intended to filter your tags based on slug?

I guess some change in the codebase between those 2 versions resulted in us no longer ignoring the bad filter - it’s not ideal as it represents a breaking change in the API, but it’s very difficult for us to test and reason about all the ways the API could be misused & make sure they don’t change behaviour!

If you look in your server console/logs you should see an error, which you can also see by doing this:

{{#get "tags" limit="all" include="count.posts" order="count.posts" filter="tags:-[getting-started]"}}
   {{#foreach tags}}

Changing the filter to use slug makes it work how I think you intended:

{{#get "tags" limit="all" include="count.posts" order="count.posts" filter="slug:-getting-started"}}
   {{#foreach tags}}

Thank you, that makes sense now.