Database error while migrating ghost

Hello. My ghost runs entirely in docker compose. I wanted to transfer all my files to a new server, but I ran into an unexpected problem. When I ran compose, I got the following error, see screenshot. At the same time, I successfully connected to the database via the console, apparently the ghost somehow connects incorrectly? I tried this on 2 of my laptops locally with macOS and linux mint, same problem.

if you delete the mariadb data, then the database will be initialized and everything will be fine, everything will work. Maybe you can somehow transfer the data to this empty new database

I managed to defeat this problem. I ran the site without the old mariadb data and got the new db files. Next, I copied the user.frm file from the new db data to the mysql folder in the old db data. Then he returned the old data to its place. In the end it helped. Apparently this file is somehow damaged during the transfer, I don’t know, but I would really like to know why this could happen