Email Newsletter

I’ve configured Mailgun with my Ghost Installation by entering Mailgun Domain and Private API Key.

The new member signup flow works smoothly. It sends the verification email to those who enter their email on the subscription page and if they click on the verification link, the email gets added as a member in Ghost.

But when I draft a new post and try to use the email newsletter feature, I get the following in spite of proper configuration with Mailgun.

Screenshot 2020-07-11 at 22.46.54

Also when I publish a new post, the subscribed members do not get any email of newly published posts.

I am having the exact same issue(one of two issues). I actually used Curl from the command line using my API and domain to verify that it works and it does.

Hey @The_Last_Benchers & @jackwxyz :wave:
Have you configured Mailgun in your production config file as well as your Ghost admin settings? More info here:

Yes, I went through that ordeal. I have mailgun in my config file for transactional emails and they work flawlessly. I put my domain and API key in the Ghost admin setting(Labs-Member Settings-mailgun.) It shows the same error that Last_Benchers has. Going into the API setting , I have redone the settings a dozen times on two different installs on two different server hosts.

thanks so much for taking the time to help.

Is there a way to test those API settings? I have done a command line test with my API keys and the email was sent.

@DavidDarnes I checked again and yes I’ve configured mailgun at both config.production.json as well as in Labs. However, I am still facing the same problem.

I have tested the mailgun configuration by inviting authors in staff section and Ghost is sending staff invitation email perfectly using mailgun. The only problem I am facing is while accessing Email Newsletter feature in Ghost editor and sending email newsletter to members.

Sending author invitations isn’t a sure fire way to test if Mailgun is connected properly. Mailgun is used to sent bulk newsletter emails, there’s a handy diagram here in our FAQ.

Before we get any deeper into the weeds, can you ensure you’re running the latest version of Ghost?

@DavidDarnes I was using v3.23.0. Just updated to v3.25.0. The problem still persists. Please let me know if you need any more details.

This problem has also been reported here: "You need to configure Mailgun in Labs to enable email newsletters."

We’re looking into it.

Going to close this thread purely because it’s not as easy to follow as the other one :slight_smile: We’ll update that one when we get to the bottom of it. If you want to add any more info - please use the main thread.

Thanks!

1 Like