Error during installation on Digital Ocean

I’ve installed Ghost on Digital Ocean multiple times and everything usually runs smoothly, however this time I am seeing an error. I have tried destroying and recreating the droplet three times. Not sure how to fix the problem.

I tried running Ghost Doctor and am seeing the message “Config file is not valid JSON”.

I am using Digital Ocean’s one-click Ghost droplet.

For some reason, your config file is invalid.

If you run cat /var/www/ghost/config.production.json, it will print your configuration. Run it through a JSON validator such as https://jsonlint.com.

I also am having the same issue. I have tried your advice and well it seems like the config file doesn’t exist at all.

Are you also using Digital Ocean’s one-click Ghost app installation? If so, I wonder if this could be a problem at their end.

I have installed Ghost multiple times (following the same process) without encountering an issue like this before.

Here is my config.production.json template if it can help :slight_smile:

Hey @DonaldH - sorry you ran into this! I know what the issue is and should have a fix out ASAP. Issue tracked here: https://github.com/TryGhost/Ghost-CLI/issues/946

1 Like

Ghost-CLI 1.11.0 is released which should fix the issue. Just created a new one-click droplet and everything worked fine :smile:

1 Like