Error in updating Ghost to v 2.9.1


#1


I tried updating my Ghost blog hosted on DigitalOcean with the following command ghost update --no-mem-check since initially it was showing me error of low memory (shows available 140 MB but required 150 MB) as was mentioned here

What exactly is the problem? Any solution?


#2

You can check the memory available with free -m.

You can upgrade your server to have more memory available or try to add swap, you can follow this tutorial https://www.digitalocean.com/community/tutorials/how-to-add-swap-space-on-ubuntu-18-04 I faced this issue in the past and this worked for me


#3

@daburix But is the problem related to memory issues? It is showing some error for Yarn.


#4

Yes, look at Error [...] spawn ENOMEM messages when installing dependencies via yarn, feel free to google it


#5


@daburix Well, I retried it again and this time I got this error. I guess, its related to memory but the swap space creation you mentioned is strictly mentioned not to be done on SSD which is what I have. I guess I have to upgrade to higher memory allocation.

@Hannah please do provide a solution if exists to update without memory upgrade.


#6

Unless you’re managing the server yourself (i.e. not through a provider like Digital Ocean or Linode, but rather using your own hardware), this isn’t really something to worry about, especially since you won’t be using the allocated swap often


#7

@vikaspotluri123 So then, shall I create the swap space and proceed ahead with the updation?


#8

Yep.

The memory bug was fixed a while back so no need to disable it anymore


closed #9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.