Error installing Ghost locally

Hi all,

I have a real problem to install locally, I’ve tried all the solutions that that there is on the forum, I found online, and I know this error appears sometimes.

OS : Mac OS Mojave (last version)
npm installed version : 6.9.0
node installed version : v10.16.0
yarn installed version : 1.16.0
homebrew is installed too

When I arrive to this command: ghost install local, it shows this:

ghost install local
:heavy_check_mark: Checking system Node.js version
:heavy_check_mark: Checking current folder permissions
:heavy_check_mark: Checking memory availability
:heavy_check_mark: Checking for latest Ghost version
:heavy_check_mark: Setting up install directory
:heavy_multiplication_x: Downloading and installing Ghost v2.25.6
A ProcessError occurred.

Message: Command failed: yarn install --no-emoji --no-progress
error An unexpected error occurred: “EACCES: permission denied, scandir ‘/Users/matt/.config/yarn/link’”.

yarn install v1.16.0
info If you think this is a bug, please open a bug report with the information provided in “/Users/matt/Documents/ghost/versions/2.25.6/yarn-error.log”.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

Exit code: 1

Debug Information:
OS: Mac OS X, v10.14.5
Node Version: v10.16.0
Ghost-CLI Version: 1.11.0
Environment: development
Command: ‘ghost install local’

Additional log info available in: /Users/matt/.ghost/logs/ghost-cli-debug-2019-07-12T08_19_48_146Z.log

Try running ghost doctor to check your system for known issues.

You can always refer to https://docs.ghost.org/api/ghost-cli/ for troubleshooting.

I’ve tried with the sudo command too, but still don’t run…
I had a funcional ghost local version (old version), but I did a clean re-install of my Mac recently

Any one had an idea? If so, it would be so useful, thanks a lot in advance, I have to work on a project, and I spend time just to try to fix this!

Thanks again!!

It looks like the installer is running into a permissions error when trying to access /Users/matt/.config/yarn/link

Yes, but how to fix this?

Before that, I had installed the older local version of ghost, and it works perfectly, with no problem with permissions,

Now I try to install the new version and that’s on my admin session, I have all the permissions

Could you share the output of /Users/matt/Documents/ghost/versions/2.25.6/yarn-error.log

how about sudo ghost install local?

@lmuzquiz : yes I’ve tried it too with sudo but it don’t works.

@vikaspotluri123 : there is nothing in the file, it’s empty, but, something really strange, I can’t go to here : /Users/matt/.config/yarn/link. because, yes this file is denied (see file attached), but I’m the administrator with all access…

04

Sounds like a yarn issue

Try this: https://stackoverflow.com/questions/48820471/yarn-permission-problems-on-osx-high-sierra

That’s probably where your issue is… can you run ls -al /Users/matt/.config so we can see what the folder permissions are? Fair warning, I have no clue how the OSX security model differs from Linux