Error when attempting update to ghost 2.x


#1

Hi!

I’m currently running ghost 1.25.5

When I run ghost update I get the following error:

“You are about to migrate to Ghost 2.0. Your blog is not on the latest Ghost 1.0 version.”

However, when I run ghost update --v1 as recommended, I am told I am already on the latest version of 1.x

Is this possibly a ghost-cli bug?

Debug Information:
OS: Ubuntu, v16.04
Node Version: v6.11.3
Ghost-CLI Version: 1.9.0
Environment: production
Command: 'ghost update'

Running ghost-doctor; everything seems fine there. I already made sure ghost-cli was the latest version (1.9.0) .


Thank you!


#3

Hey @Rose :wave: you found a bug in the CLI :see_no_evil: A new CLI version has been released with a fix :smile:

To update the CLI, run sudo npm i -g ghost-cli@latest

after doing, that, running ghost update should let you upgrade to 2.0.1 :tada:


#4

Oh I didn’t know we had that bug, it didn’t happened to me :confused: That was a quick fix.


#5

@vikaspotluri123 wow that was fast! Thanks :smile: Your fix worked perfectly for me!


#6

Hi guys updated to Ghost 2.0 and now my blog is returning Bad Gateway. I received an error “Failed to start ghost.service: Unit ghost.service not found.”

My ghost is now on 2.0.2. I run ghost update and it says everything is fine with the installation and why am I on bad gateway,


#8

I got the same error on 1.25.3 but then ran:

  • ghost update --force

to get to 1.25.5, it seemed to show an error getting dependencies but then sorted itself?! then ran:

  • ghost update

Which then got me to 2.0.3, no issues.


#9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.