Error While Reinstalling Ghost?

Hi there,

I’m trying to get back into blogging, and as such, want to get my completely untended ghost instance back up to date. I’m self-hosting Ghost on a Linode server running Ubuntu 18.04 LTS. It’s a little embarrassing, but I’m running Ghost 2.4.0. Using the documentation here, I’ve run into an error when checking my Node version.

I’m getting this error when trying to check my node version:
node: /lib/x86_64-linux-gnu/ version GLIBC_2.28’ not found (required by node)`

From what I could tell, it was an issue with my Node version, so I went ahead and installed nvm, uninstalled node, and then reinstalled node using nvm install node, which returned:

Now using node v19.7.0 (npm v)
Creating default alias: default -> node (-> v19.7.0)

Even so, I’m still getting this error when trying to check the node version or install the Ghost CLI tools using sudo npm install -g ghost-cli@latest.

What can I do to fix this? Honestly, I made an exported JSON file, but I would be fine just starting from scratch if that’s an easier process that upgrading such an outdated version.

Thanks in advance.

Edit: Using ldd --version, I determined I have GLIBC 2.27. I tried to use npm install to install first Node version 16.19.1 and then 14.21.3, but I still get the same error about GLIBC 2.27 when trying to run the command sudo npm install -g ghost-cli@latest.

Unfortunately, you are so far behind that the only pragmatic option is to do a fresh install of Ghost.

Ideally, roll-back to a recent snapshot or backup, and then export the current blog content.

Then fire up a new Linode running either 20.04 or 22.10, and install the latest version of Ghost.

Finally, import your content.

Once this is done, you can destroy the original Linode.

Got it, thanks. I figured I was sort of “too far gone” here. I’ve gone ahead and reinstalled everything from scratch, and seem to be back up and running. Thanks!

1 Like