Excerpt not included in email

I’ve just discovered that when you send a post via email, it does not include the excerpt in the body.

As such, the preview of the email shows the first few words of the except, but when you actually view the email, the excerpt is nowhere to be seen. It jumps straight into the body content.

I don’t want to include the excerpt in the body copy as well otherwise on the website it gets duplicated.

So, as the excerpt IS being included in the email code, could it also actually show in the email template?

1 Like

It sounds you may be abusing the excerpt feature a bit. The custom excerpt field designed to be used as a short description or excerpt of the post content, not as part of the post content itself so there will likely be a number of cases like this email one where things aren’t how you expect.

How are you using the custom excerpt in your site content?

The short version: From what I can see the email and the LYRA post template need to work the same way and presently they do not. One includes the excerpt above the content and the other does not.


The longer version

The excerpt for me is a ‘lead in’ to a story.

For example. Go to the BBC News website. You’ll see a short excerpt / summary of the story. When you click in, you will not see that same text again.

So for me, an excerpt is a small summary of the story.

Right now, if you put an excerpt it gets shown at the top of the post on the website using your Lyra theme. As I would expect.

As a result, I do NOT put the same excerpt copy in again to the body of the story otherwise the page shows the same content repeated above and below the featured image.

However, when you send an email. The excerpt is used for the ‘preview’ text but is not shown in the body, so now I am missing that content all together.

Right now based on the Lyra theme and the functionality I have 2 options

  1. Write a post, copy the first part into the excerpt, end up with it duplicated on the page, but included once in the email
  2. Write a post, write a different ‘into’ in the excerpt. Have the webpage post read well but the email now missing part of the content
1 Like

This is expected behaviour because the excerpt is Public and included above the byline on all posts whether the visitor is a logged in member or not.

I use Lyra myself and I use the excerpt as a standalone description to encourage visitors to sign up, so it works well for this use case not to include excerpts in email newsletters.

However, I totally understand your use case of using the excerpt as a lead in to your story and your feedback has been noted with the team :slight_smile:

You could get around this as of right now by using your first method:

  1. Write a post, copy the first part into the excerpt, end up with it duplicated on the page, but included once in the email

But as soon as the post is published/delivered - you can immediately remove the duplicate content so it doesn’t appear on your site.

I realise this is a bit of a workaround - but since this feature is in Beta, it’s not yet possible to customise the email template itself.

Hey @fimo - we just released a new feature that allows you to use cards to place content in your emails that doesn’t appear in your published post. Thought this might be a good solution for your needs :slight_smile:

Thank you Kym, somehow I missed this reply.

Any word on membership tiers? :wink: