Featured Image not load after install SSL Bitnami Apache

Hi, I have recently create a ghost site on AWS EC2. I use Bitnami Ghost Image to install ghost. This image uses apache for web server. And my ghost cms version is 3.9.0 .

I use Cloudflare for map dns. But proxy is disabled on dns is enabled.

I use Chrome to browser my site.

After installation complete I open ghost website and Admin dashboard. Everything seems right. I create a test post, write some content, add some images and a feature image. Then post it. When I view the post it ok. Everything load perfect.

After that i Install SSL certificate using a command that is provided by bitnami blog.


After that I see the post again that I create previews and also home. Every this load perfect, But feature image is not load both in home page and post page. When I inspect feature post using right click and then inspect, Image URL is starting from http:// not from https:// .

After that I also use a command

ghost config url https://sharebites.xyz

But nothing happen.

Now my config.production.json file settings is like that

  "url": "http://sharebites.xyz",
  "urlSSL": "https://sharebites.xyz",
  "server": {
    "port": 2368,
    "host": ""
  "database": {
    "client": "..................",
    "connection": {
      "host": "..................",
      "user": "..................t",
      "password": "..................",
      "database": ".................."
  "mail": {
    "transport": "Direct"
  "logging": {
    "transports": [
  "process": "local",
  "paths": {
    "contentPath": "/opt/bitnami/apps/ghost/htdocs/content"

I remove Database username, password and database name with ‘…’ for security purpose.

Now feature image will load. But my website some time load on SSL and some time not on SSL.

Now feature image address is relative address in inspect. and other post content images still use absolute address with http://

Please help me.


Did you find the solution?
I am facing same issue. can you help me ?


you need to set
RequestHeader set X-Forwarded-Proto "https"
in your Apache configuration.

Have a look at

1 Like

hi @deepak36,
my case is very similar to yours, but my site can always do https, including the feature image, but all other images in the post body content will be shown in http. very strange.

i have followed the links provided by @MartinGross , and it did help ~

just that the path to “httpd-app.conf” should be :


and it now works for me. hope this will also solve yours ~

my post asking for help in this issue :