Images are not loading and image url have http://localhost

I have installed ghost from AWS bitnami AMI in an EC2 instance. Ghost version is 5.26.3.
The blog is hosted at https://nixhacker.com.
Everything in blog is working fine expect the images in the post and many other places are not displayed and have url of http://localhost rather than https://nixhacker.com/XX.

Here is my config.production.json

{
  "database": {
    "client": "mysql",
    "connection": {
      "host": "127.0.0.1",
      "port": 3306,
      "database": "bitnami_ghost",
      "user": "....",
      "password": "...",
      "ssl": false
    }
  "mail": {
  "from": ".....",
  "transport": "SMTP",
  "options": {
    "host": ".....",
    "service": ".....",
    "port": "465",
    "secure": true,
    "auth": {
      "user": ".....",
      "pass": "....."
    }
  }
  },
  "url": "https://nixhacker.com",
  "server": {
    "port": 2368,
    "host": "0.0.0.0"
  },
  "mail": {
    "transport": "Direct"
  },
  "logging": {
    "transports": [
      "file"
    ]
  },
  "process": "local",
  "paths": {
    "contentPath": "/opt/bitnami/ghost/content"
  }
}

Any help will be appreciated.

Your site in inaccessible because the connection is not private, i.e., the certificate is invalid.

Moreover, you appear to have setup a development installation rather than production.

Please provide details of the version of Ghost you’re running, including the steps you’ve taken to install Ghost.