Files consistently have the wrong permissions each "ghost upgrade"

Almost every single time I run “ghost upgrade” I get errors saying I need to run a sudo chmod command to change a bunch of files to permission 644:

sudo find ./ ! -path ". */versions/* *" -type f -exec chmod 664 {} \;

Just wondering, but why does this issue keep happening in the first place? Can the system just fix the problem itself if it already knows the command to run? Also why should the files even have the wrong permissions to begin with? I never change anything yet it keeps happening over and over and this blog isn’t even being used yet, just the “default” setup for testing basically…

Not a big deal really, purely curious lol since I am developer…

Thanks for help, all

Best Regards,


Same here. I made no change to any theme or core file between 4.3.x and 4.3.3 and got the same error.

I always get that error.

Same. I have that exact code in my home-grown updater script. Never found the cause, but the code snippet works around it.

Normally the file permission problem is caused by the theme folder, u can work it around by changing theme to the default and update ghost then change theme back.

What i do solve the problem is to set a soft link of your_ghost_folder/current/content/theme/your_theme to your_ghost folder/content/theme/your_theme