[FIXED] Multiple blogs on subdirectories - OK with ghost run, but stuck at the systemctl stage


#1

EDIT: I think I found the problem - during the ghost setup stage, I wanted to ignore all the stuff about ssl, nginx etc (ghost likes to totally destroy existing, working nginx installs when it comes to ssl!).
But it seems like my “n” response was getting “carried over” to the bit about systemd.I didn’t notice this in my tired state at midnight last night! THis morning, I just had to very quickly “tap” the n or y, and this time it worked!

The problem

ℹ Setting up Nginx [skipped]
Task ssl depends on the 'nginx' stage, which was skipped.
ℹ Setting up SSL [skipped]
? Do you wish to set up Systemd? No
ℹ Setting up Systemd [skipped]

ORIGINAL QUESTION

I want to create 2 more copies of a blog for a/b/c testing, as well as other fiddling and tweaking (so I can’t play while not messing up the live site!)

I read this


and this

Fortunately, I’m using sqlite, so I just modified the nginx.conf and config-production files.
But the copy-blog wouldn’t start. It runs just fine with ghost run, and if I do systemctl start ghost_myblog.service it’s fine, but systemctl start ghost_myblog2.service fails.

Now, what I’ve done is modify the startup directory in /var/www/blog2/system/files/ghost_myblog2.service and then symlink it to /lib/systemd/system like blog1 had done.

But in either directory “ghost start” seems to randomly either start (or fail to start) the main blog.

At this point, I’m pretty much out of my depth when it comes to messing with systemd. The digitalocean blog above says

“Currently, there is a System V init script located at /etc/init.d/ghost. If you are following this guide, delete the old System V script. This will help avoid confusion and can prevent the service starting with the wrong settings:”

I’m not sure why it’s this tricky - where am I going wrong? Thanks!

BTW - here’s the log output - I can confirm that the ports are free, and that “ghost run” works for both blogs, at the same time. It’s just that “ghost start/restart” fails.

    Original Error Message:
    Message: connect ECONNREFUSED 127.0.0.1:2369
    Stack: Error: connect ECONNREFUSED 127.0.0.1:2369
        at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1191:14)
  • What’s your URL? Private for now
  • What version of Ghost are you using? 2.1.3
  • What configuration? Ubuntu/sqlite3/nginx/node 8.11
  • What steps could someone else take to reproduce the issue you’re having? See above

#2

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.