Ghost 3.0.2 - Signin or Signup - 404 error

Hello all,

After upgraded to latest version and tried some themes compatible with the functions Memberships & subscriptions, always i have a 404 error when pushed buttons signin or signup and access to https://blog.<domain.com>/signin/ or https://blog.<domain.com>/signup/

All others parts, posts, pages, tags etc can be access without any error.

Example with Lyra theme:

Members functions activate:

Configuration:
Self Hosting
OS: Debian, v10
Node Version: v10.17.0
Ghost-CLI Version: 1.12.0
Ghost version: 3.0.2
Nginx Version: 1.16.1
Browser: Firefox 69.0.3 or Safari 13.0.3

Nginx config:

...    
server {                                                                                                                       
            listen 443 ssl http2;                                                                                                  
            listen [::]:443 ssl http2;                                                                                             
                                                                                                                                   
            server_name blog.domain.com;
                                                                                                                               
            location / { 
                    resolver 9.9.9.9 149.112.112.112;
                    set $ghost_url http://127.0.0.1:2368;
                    proxy_pass $ghost_url;
                    proxy_redirect off;
                    proxy_set_header Host $http_host;
                    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;                                                   
                    proxy_set_header X-Forwarded-Proto $scheme;                                                                    
                    proxy_set_header X-Real-IP $remote_addr;                                                                       
            }                                                                                                                      
    ...                                                                                         
    }

Ghost logs:

[2019-11-01 19:41:52] WARN Cookie ghost-members-ssr not found
[2019-11-01 19:41:52] INFO "GET /signin/" 404 103ms

[2019-11-01 19:43:39] WARN Cookie ghost-members-ssr not found
[2019-11-01 19:43:39] INFO "GET /signup/" 404 91ms

Has anyone ever encountered this error?
If so, how can it be solved?

Of course, any idea / help is welcome :smile:

Did you upload the routes.yaml as mentioned in the theme instructions? https://github.com/TryGhost/Lyra#instructions

1 Like

Yes i previously uploaded it but seems i’m wrong folder …
Because i retry after your answer and maybe more focus and you are right it’s perfect like this and solve this issue.

After upload correct routes.yaml:

Thank you Kevin for your quick answer and help.