Ghost Apache Mixed Content #site

#1

I installed Ghost with Apache without encountering any problems.
I installed the https with let’s encrypt.
The blog works correctly with https.
I noticed that in the new section in the back-end “View site” I don’t see the anything, I get the following error in console:

Mixed Content: The page at https://domain.it/ghost/#/site 'was loaded over HTTPS, but requested an insecure resource' http://domain.it/ '. This request has been blocked; the content must be served over HTTPS.

In the config-production.json file I have “url”: "http://domain.it"
If I change to https and restart apache, the site no longer works:
Too many redirects.

How can I solve it?
Thank you

#2

You need to map the nginx config that’s used to the equivalent apache config. The important rule is setting and forwarding the x-forwarded-proto header

1 Like
closed #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.