Ghost install failed-ubuntu 22.04

:heavy_check_mark: Checking system Node.js version - found v18.19.0

:heavy_check_mark: Checking current folder permissions

:heavy_check_mark: Checking memory availability

:heavy_check_mark: Checking free space

:heavy_check_mark: Checking for latest Ghost version

:heavy_check_mark: Setting up install directory

:heavy_multiplication_x: Downloading and installing Ghost v5.75.2

A ProcessError occurred.

Message: Command failed: yarn install --no-emoji --no-progress

warning ghost@5.75.2: The engine “cli” appears to be invalid.

warning Error running install script for optional dependency: "/home/ghost/ghost2/versions/5.75.2/node_modules/@newrelic/native-metrics: Command failed.

Exit code: 1

Command: node ./lib/pre-build.js install native_metrics

Arguments:

Directory: /home/ghost/ghost2/versions/5.75.2/node_modules/@newrelic/native-metrics

Output:

============================================================================

Attempting install in native-metrics module. Please note that this is an

OPTIONAL dependency, and any resultant errors in this process will not

affect the general performance of the New Relic agent, but event loop and

garbage collection metrics will not be collected for the Node VMs page.

============================================================================

Download error: No pre-built artifacts for your OS/architecture., falling back to build

/usr/bin/node /home/ghost/ghost2/versions/5.75.2/node_modules/node-gyp/bin/node-gyp.js clean configure

gyp info it worked if it ends with ok

I ran into this recently. Click through my profile to find my recent posts or try searching for native metrics.

I’m facing the same issue here with the last update, tried to follow this instructions but it stills giving the same error message.

What can I try?

I’m not sure what else to suggest besides what I posted.

There’s the nuclear option to start with a new server and move your data over.

You could try posting your exact versions of your OS, Node, Ghost and MySQL and your exact errors or logs and maybe someone can help.

It might get more visibility as a new topic that you link to here.

It was solved on last version of Ghost, perhaps because an incompatibility between previous versions of all apps mentioned.

Thanks al always, Mark! :)