Ghost Installation & Rebuilding issues

Hey Community,

I am a newbie exploring the Ghost platform. It might be a very basic thing which I am missing.

I have overridden the current theme - casper and am using 3.2.2 version of ghost locally. I did that in another system and was using version control, now when I cloned my repo and tried running it on another system, the debug log provides the following information:

Found a development config but not a production config, running in development mode instead
:heavy_check_mark: Checking current folder permissions
:heavy_check_mark: Validating config
:heavy_check_mark: Checking memory availability
:heavy_check_mark: Checking binary dependencies
:heavy_multiplication_x: Starting Ghost: ghost-local
A GhostError occurred.

Message: Ghost process exited with code: 0

Debug Information:
OS: Mac OS X, v10.14.1
Node Version: v10.16.3
Ghost Version: 3.2.0
Ghost-CLI Version: 1.13.1
Environment: development
Command: ‘ghost start’

Meanwhile, the log states that
Message: Ghost process exited with code: 0
Stack: Error: Ghost process exited with code: 0
at ChildProcess.cp.on (~/.nvm/versions/node/v10.16.3/lib/node_modules/ghost-cli/lib/utils/local-process.js:56:24)
at ChildProcess.emit (events.js:198:13)
at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)

Which doesn’t provide me with info insight to debug.

I would be more than happy to listen to community feedback on same, if they are facing the same issue & the best practises to manage ghost platform locally for my team.

Thanks in advance for your valuable time.

Hi there. It might be that some of the files on the previous machine were not committed and pushed to your repo. Did you make sure to run through the build steps of the theme before starting?

@DavidDarnes I have solved the issue, basically, the symlink to the ‘current’ was wrong.
I unlinked ‘current’, then using the command ln -s myGhostVersion current I created the new symlink.

It solved my problem, in the future if someone comes across this, s/he may find this solution useful.
In case you are still facing issues, debug using this command ghost run -D, it was quite helpful in finding whether the port was occupied / not and there were issues in theme files.

1 Like