Ghost is not installing on digital ocean

I have tried to install ghost using droplet on Digital Ocean. I got an error. But I am not getting the solution.

Configuring DigitalOcean 1-Click Ghost installation.

Please wait a minute while your 1-Click is configured.

Once complete, you are encouraged to run mysql_secure_installation to ready
your server for production. Passwords have been saved to:



Ensuring Ghost-CLI is up-to-date...
+ sudo npm i -g ghost-cli@latest
[..................] \ fetchMetadata: sill resolveWithNewModule yarn@1.22.10 checking installable status                                                                                    [..................] | fetchMetadata: sill resolveWithNewModule yarn@1.22.10 checking installable status                                                  [..................] | fetchMetadata: sill resolveWithNewModule color-convert@2.0.1 checking installable status                  
/usr/bin/ghost -> /usr/lib/node_modules/ghost-cli/bin/ghost
+ ghost-cli@1.15.3
added 26 packages from 16 contributors, removed 17 packages, updated 51 packages and moved 6 packages in 37.425s

Ghost will prompt you for two details:

1. Your domain
 - Add an A Record -> & ensure the DNS has fully propagated
 - Or alternatively enter
2. Your email address (only used for SSL)

Press enter when you are ready to get started!

+ sudo chown -R ghost-mgr:ghost-mgr /home/ghost-mgr/.config
✔ Checking system Node.js version
✔ Checking logged in user
✔ Checking current folder permissions
✔ Checking system compatibility
✔ Checking for a MySQL installation
✔ Checking memory availability
✔ Checking free space
✔ Checking for latest Ghost version
✔ Setting up install directory
✔ Downloading and installing Ghost v3.40.5
✔ Finishing install process
? Enter your blog URL:
✔ Configuring Ghost
✔ Setting up instance
+ sudo useradd --system --user-group ghost
+ sudo chown -R ghost:ghost /var/www/ghost/content
✔ Setting up "ghost" system user
ℹ Setting up "ghost" mysql user [skipped]
+ sudo mv /tmp/kaminskiplus-de/ /etc/nginx/sites-available/
+ sudo ln -sf /etc/nginx/sites-available/ /etc/nginx/sites-enabled/
+ sudo nginx -s reload
✔ Setting up Nginx
? Enter your email (For SSL Certificate)
+ sudo mkdir -p /etc/letsencrypt
+ sudo ./ --install --home /etc/letsencrypt
+ sudo /etc/letsencrypt/ --issue --home /etc/letsencrypt --domain --webroot /var/www/ghost/system/nginx-root --reloadcmd "nginx -s reload" --accountemail
✖ Setting up SSL
+ sudo mv /tmp/kaminskiplus-de/ghost_kaminskiplus-de.service /lib/systemd/system/ghost_kaminskiplus-de.service
+ sudo systemctl daemon-reload
✔ Setting up Systemd
+ sudo systemctl is-active ghost_kaminskiplus-de
+ sudo systemctl start ghost_kaminskiplus-de
+ sudo systemctl is-enabled ghost_kaminskiplus-de
+ sudo systemctl enable ghost_kaminskiplus-de --quiet
✔ Starting Ghost
One or more errors occurred.

1) ProcessError

Message: Command failed: /bin/sh -c sudo -S -p '#node-sudo-passwd#'  /etc/letsencrypt/ --issue --home /etc/letsencrypt --domain --webroot /var/www/ghost/system/nginx-root --reloadcmd "nginx -s reload" --accountemail
[Sat Jan 16 20:45:31 UTC 2021] error:Invalid response from [2606:4700:3037::ac43:c239]:
[Sat Jan 16 20:45:31 UTC 2021] Please add '--debug' or '--log' to check more details.
[Sat Jan 16 20:45:31 UTC 2021] See:

[Sat Jan 16 20:45:24 UTC 2021] Using CA:
[Sat Jan 16 20:45:24 UTC 2021] Create account key ok.
[Sat Jan 16 20:45:24 UTC 2021] Registering account:
[Sat Jan 16 20:45:25 UTC 2021] Registered
[Sat Jan 16 20:45:25 UTC 2021] ACCOUNT_THUMBPRINT='MeGBylrE1fTwmzBGd_FtEokW60E6HEXUypsc2jbIX_k'
[Sat Jan 16 20:45:25 UTC 2021] Creating domain key
[Sat Jan 16 20:45:26 UTC 2021] The domain key is here: /etc/letsencrypt/
[Sat Jan 16 20:45:26 UTC 2021] Single domain=''
[Sat Jan 16 20:45:26 UTC 2021] Getting domain auth token for each domain
[Sat Jan 16 20:45:27 UTC 2021] Getting webroot for domain=''
[Sat Jan 16 20:45:27 UTC 2021] Verifying:

Exit code: 1

Debug Information:
    OS: Ubuntu, v18.04.4 LTS
    Node Version: v12.18.0
    Ghost Version: 3.40.5
    Ghost-CLI Version: 1.15.3
    Environment: production
    Command: 'ghost install --auto --db=mysql --dbhost=localhost --dbname=ghost_production --dbuser=ghost --dbpass=58486a38b83ea8e04686c81b60b9d04e094ddc0e1a8f452e --dir=/var/www/ghost --start'

Additional log info available in: /home/ghost-mgr/.ghost/logs/ghost-cli-debug-2021-01-16T20_45_58_995Z.log

Try running ghost doctor to check your system for known issues.

You can always refer to for troubleshooting.


For any further commands, please switch to the ghost-mgr user to manage Ghost.

    sudo -i -u ghost-mgr


root@ghost-ubuntu-s-1vcpu-2gb-nyc1-01:~# ghost doctor
You can't run commands as the 'root' user.
Switch to your regular user, or create a new user with regular account privileges and use this user to run 'ghost doctor'.
For more information, see

Looking for your help

Best Regards
Enamul Haque

Seems like it’s erroring out while setting up SSL…

& You are using Cloudflare dns

With cloud flare to issue LE ssl you need to make the A record & www record entry DNS only from proxied…

Hope it will help you

i just installed a new instance minutes ago, working out of the box here.

about the A and www records, try something like this:

Hi @inoryum and @matheus-rossi ,
I already created A record and CNAME record but it is not working.
Did I make any mistake?

Change the dns settings from proxied to dns only … That’s means the orange cloud icon make that gray …

Just to issue the LE certificate…

1 Like

Thank you so much

Happy to help!