Ghost v4.6.1 is not compatible with the current Node version

Related (I think): A week or so ago I set up a new droplet at Digital Ocean for multiple Ghost sites. I ran into this problem when trying to install the second and third sites. I then noticed that the default one-click installation for the first site was using Ghost 4.4. For the second and third sites, I tried version v4.4 and had no issues.

Based on the stats, the file does exist, so I’m not entirely sure where to go from here - the error is a node error saying
/home/ljhardy/public_html/firehole.us/versions/4.6.4/core/server/lib/ghost-version.js does not exist, but as you can see, it does exist :confused:

Are the permissions right on ghost-version.js?

Access: (0644/-rw-r–r–) Uid: ( 1000/ ljhardy) Gid: ( 1000/ ljhardy)

The others listed are 775.

You can try changing it to 755, but I don’t know if that will fix the issue

You’re right, that didn’t help. I think what shows up in ghost log -error depends on where the start script is in the “looping” process. This is what I see now:

[2021-06-07 12:26:34] ERROR

CODE: ERR_SERVER_NOT_RUNNING
MESSAGE: Server is not running.

Error [ERR_SERVER_NOT_RUNNING]: Server is not running.
at Server.close (net.js:1606:12)
at Object.onceWrapper (events.js:421:28)
at Server.emit (events.js:315:20)
at Server.EventEmitter.emit (domain.js:467:12)
at emitCloseNT (net.js:1659:8)
at processTicksAndRejections (internal/process/task_queues.js:79:21)

Can you try making your url https?

Hmm. I read a few other posts with a similar looping problem: Ghost run works for me:

Ghost run – works
Ghost start --loops, does not work.

Yes, would like to confirm this. Ghost 4.6.6. doesn’t seem to upgrade with this version of node. I’ve also tried upgrading node.js following these instruction – no luck with ghost upgrade post that either.

Yes @jpm – I did successfully update all of my (about 30) Ghost sites to v4.6.5 yesterday after upgrading node.js to v14.16.1

May I ask if you were following the same instructions, or could you share what you did.

@jpm I also had to update Ghost-CLI to version: 1.17.3

If I can think of anything else I’ll let you know…

Thanks. Managed to upgrade to latest version of GhostCLI and that worked.