Minimum Node.js Versions changing to 12.22.1 & 14.16.1 (Node v10 is EOL)

As of the next Ghost release (v4.5.0), the minimum supported versions of Node.js will be changing.

Node.js v10 became end of life on April 30th 2021, therefore it will no longer be supported.

Node v12 and Node v14 have both had numerous security fixes and so we will take this opportunity to also push support to the latest, secure versions.

How to Upgrade

You can upgrade in advance :slight_smile:

  1. curl -sL | sudo -E bash to update your source list to Node.js v14 (recommended)
  2. sudo apt-get install -y nodejs to upgrade Node.js
  3. Run ghost version to get your current Ghost version
  4. ghost update [version] --force to force Ghost to reinstall your current version of Ghost, to trigger a re-install of dependencies without reinstalling Ghost.

:warning: If you are on a version of Ghost in the range >=4.0..0 <4.3.3 you may not be able to run ghost update [version] --force as these versions are insecure. If it fails, you should instead run ghost update 4.3.3 --force to do the minimum upgrade.

More details about supported versions and how to upgrade can always be found in our docs:

If you haven’t already seen, you should also upgrade to at least Ghost 4.3.3


if you are manually installing ghost (via curl or yum) - i’d instead recommend using NVM instead to manage your installed node versions. upgrading to Node 12 β†’ 14 was a breeze!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.