Have not figured out how to log into a new Ghost blog with SSH

I just successfully installed the latest Ghost on Ubuntu 18.04. Everything seems to be working perfectly. I want to upload a custom font, and have encountered a mystery: I seem to be unable to get into the site using a terminal program.
I am operating the site from a Windows 10 laptop. I have tried PuTTY, WinScp, FileZilla and the Windows Ubuntu terminal. I am very familiar with SSH and have never had a problem before or with any other URL. However, no matter whether I try to SSH into the site by its URL (notes.numuzu.com), or by its IP, the same roadblock occurs: nothing in the terminal window ever happens. It just sits there, blank. I’ve tried logging in as root, and as my sudo user, and as my Ghost user. Ghost appears to have modified my Ubuntu configuration to lock out everybody.
Is there a specific port I should be using for SSH?
Any hints would be appreciated.

Totally hear your frustration, but this doesn’t sound like it’s anything to do with Ghost. It doesn’t modify anything to do with your SSH config.

Thanks! That helps me know where to start troubleshooting. Much appreciated.

You haven’t detailed the specific command are you running - it makes it much easier to help.

To see what ssh is doing during connection use ssh -v

Add more 'v’s to get more info e.g. ssh -vv

SSH rarely hangs forever - it usually times out with an error. It’s possible you are being blocked by a firewall. Also, I am guessing that if you are installing a font from your Windows laptop you are probably running scp rather than ssh?

So rereading your post - you are probably not using ssh but rather clicking on an icon and launching a terminal (e.g. PuTTY) which is set up to auto-connect using the ssh protocol.

I have run an nmap on your host with the following results:

Nmap scan report for notes.numuzu.com (
Host is up (0.15s latency).
Not shown: 998 filtered ports
80/tcp  open  http
443/tcp open  https
Nmap done: 1 IP address (1 host up) scanned in 57.15 seconds

Which unless you are using an advanced firewall on your Ubuntu server, tells me that you are not running the ssh server on your host - there is nothing for your terminal to connect to.

You should investigate exactly how you set up the SSH Server daemon on your host.

Jeff, thanks very much for looking into this. After seeing the initial response, I went back and discovered that I had enabled the UFW firewall while installing nginx, assuming that was the right thing to do, and the firewall was keeping me out. When I install Ghost without the UFW enable command, there is no problem.
I’m not using my usual setup, which is Ubuntu 18.04 on a desktop, but instead I’m using a Win 10 laptop with PuTTY, WinSCP, and FileZilla, as well as the add-on Ubuntu terminal program. None worked with UFW enabled on the server I was attempting to communicate with, obviously.
Again, thanks for taking the time to look at this problem.

1 Like