Cannot access our newly created blog

Hi everybody !

I just freshly installed the self-hosted Ghost with the CLI command and everything was fine untill I started the ghost server and tried to access the blog with the URL I wrote during the installation but I don’t get any response from the blog and the Chrome white page “The website isn’t working”…
Can someone help me ?

Here is the config file in my ghost directory in “/var/www/ghost”:
{ “url”: “”, “server”: { “port”: 2368, “host”: “” }, “database”: { “client”: “mysql”, “connection”: { “host”: “localhost”, “user”: “ghost”, “password”: “test”, “database”: “ghost_prod” } }, “mail”: { “transport”: “Direct” }, “logging”: { “transports”: [ “file”, “stdout” ] }, “process”: “systemd”, “paths”: { “contentPath”: “/var/www/ghost/content” } }

I used the recommended stack but instead of Ubuntu i’m using Debiant 8.
I tried connection with direct IP and port but same result

Thanks !

what is your nginx configuration for that blog? Did you configure it properly?

Here is my config for the blog :

server {
listen 80;


  return 301 https://$server_name$request_uri;


server {
listen 443 ssl;

 ssl on;
 ssl_certificate /etc/letsencrypt/live/;
 ssl_certificate_key /etc/letsencrypt/live/;


location /
        proxy_pass http://localhost:2368;
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection 'upgrade';
        proxy_set_header Host $host;
        proxy_cache_bypass $http_upgrade;


I’m guessing that “” is not a domain you own, and you haven’t configured to point at your server.

You need to use a domain that you own and control, and point it at your server using an A Record.

1 Like

I just changed my own domain for “” for the example, I already setup the A record for the blog on my DNS record

in my troubleshooting experience today, you should get at least an nginx generic page if you hit your url with correct DNS settings and nginx running.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.