Cannot access our newly created blog


#1

Hi everybody !

I just freshly installed the self-hosted Ghost with the CLI command and everything was fine untill I started the ghost server and tried to access the blog with the URL I wrote during the installation but I don’t get any response from the blog and the Chrome white page “The website isn’t working”…
Can someone help me ?

Here is the config file in my ghost directory in “/var/www/ghost”:
{ “url”: “https://blog.test.com”, “server”: { “port”: 2368, “host”: “127.0.0.1” }, “database”: { “client”: “mysql”, “connection”: { “host”: “localhost”, “user”: “ghost”, “password”: “test”, “database”: “ghost_prod” } }, “mail”: { “transport”: “Direct” }, “logging”: { “transports”: [ “file”, “stdout” ] }, “process”: “systemd”, “paths”: { “contentPath”: “/var/www/ghost/content” } }

I used the recommended stack but instead of Ubuntu i’m using Debiant 8.
I tried connection with direct IP and port but same result

Thanks !


#2

what is your nginx configuration for that blog? Did you configure it properly?


#3

Here is my config for the blog :

server {
listen 80;

  server_name blog.test.com;

  return 301 https://$server_name$request_uri;

}

server {
listen 443 ssl;

 ssl on;
 ssl_certificate /etc/letsencrypt/live/blog.test.com/fullchain.pem;
 ssl_certificate_key /etc/letsencrypt/live/blog.test.com/privkey.pem;

 server_name blog.test.com;

location /
{
        proxy_pass http://localhost:2368;
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection 'upgrade';
        proxy_set_header Host $host;
        proxy_cache_bypass $http_upgrade;
}

}


#4

I’m guessing that “test.com” is not a domain you own, and you haven’t configured blog.test.com to point at your server.

You need to use a domain that you own and control, and point it at your server using an A Record.


#5

I just changed my own domain for “test.com” for the example, I already setup the A record for the blog on my DNS record


#6

in my troubleshooting experience today, you should get at least an nginx generic page if you hit your url with correct DNS settings and nginx running.


#7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.