How do i get rid of times new roman?

I am creating an about me page and i can not get rid of the times new roman font.
I have tried getting the Poppins font but nothing seems to work.
Please help me!

Fonts are generally set at the theme level. Couple questions to help you:

Which theme are you using?
How are you adding Poppins?
Do you have a live page we can check out to help troubleshoot?

Thanks for replying!
I am using Casper.
I am injecting css code into the code injector.

I don’t think you’re correctly setting up the font family. I don’t see it.

To get rid of the serif, try this:

.gh-content > * {
    font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen, Ubuntu, Cantarell, 'Open Sans', 'Helvetica Neue', sans-serif!important;

To specifically get Poppins, add this:

<link rel="preconnect" href="">
<link rel="preconnect" href="" crossorigin>
<link href="" rel="stylesheet">

and THEN you can set Poppins where you want it:

font-family: 'Poppins', sans-serif;

(the above needs to go into a selector, like my first example, not get pasted alone.)

Or you can redefine the theme’s definition:

root {
 --font-serif: Poppins, sans-serif;
 --font-sans: Poppins, sans-serif;

(But you still need those links above.)

One other, less technical option if you’re just after a sans-serif font. Go to Settings → Design and choose the “Modern sans-serif” option for Body font.

Will that apply to my pages? i want to have the same font i use on the casper home page. But i get times new roman on it now.

Did you try it? It’ll also apply to your posts/pages.

It works now!